summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--src/extras/gudev/gudevdevice.c4
2 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 83e5fa31d..d3d9570e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -479,6 +479,8 @@ src/extras/gudev/GUdev-1.0.gir: src/extras/gudev/libgudev-1.0.la $(G_IR_SCANNER)
--output $@ \
--pkg=glib-2.0 \
--pkg=gobject-2.0 \
+ --pkg-export=gudev-1.0 \
+ --c-include=gudev/gudev.h \
-I$(top_srcdir)/src/extras \
-I$(top_builddir)/src/extras \
-D_GUDEV_COMPILATION \
diff --git a/src/extras/gudev/gudevdevice.c b/src/extras/gudev/gudevdevice.c
index 0c3340ffe..62a26f99b 100644
--- a/src/extras/gudev/gudevdevice.c
+++ b/src/extras/gudev/gudevdevice.c
@@ -373,7 +373,7 @@ g_udev_device_get_device_file_symlinks (GUdevDevice *device)
*
* Gets the immediate parent of @device, if any.
*
- * Returns: A #GUdevDevice or %NULL if @device has no parent. Free with g_object_unref().
+ * Returns: (transfer full): A #GUdevDevice or %NULL if @device has no parent. Free with g_object_unref().
*/
GUdevDevice *
g_udev_device_get_parent (GUdevDevice *device)
@@ -404,7 +404,7 @@ g_udev_device_get_parent (GUdevDevice *device)
* Walks up the chain of parents of @device and returns the first
* device encountered where @subsystem and @devtype matches, if any.
*
- * Returns: A #GUdevDevice or %NULL if @device has no parent with @subsystem and @devtype. Free with g_object_unref().
+ * Returns: (transfer full): A #GUdevDevice or %NULL if @device has no parent with @subsystem and @devtype. Free with g_object_unref().
*/
GUdevDevice *
g_udev_device_get_parent_with_subsystem (GUdevDevice *device,