summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--man/systemd.snapshot.xml87
-rw-r--r--man/systemd.unit.xml11
3 files changed, 95 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c5568e211..6334b561e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -325,6 +325,7 @@ MANPAGES = \
man/systemd.path.5 \
man/systemd.target.5 \
man/systemd.device.5 \
+ man/systemd.snapshot.5 \
man/daemon.7 \
man/sd-daemon.7 \
man/runlevel.8 \
diff --git a/man/systemd.snapshot.xml b/man/systemd.snapshot.xml
new file mode 100644
index 000000000..5e73cc6f7
--- /dev/null
+++ b/man/systemd.snapshot.xml
@@ -0,0 +1,87 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<?xml-stylesheet type="text/xsl" href="http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd.snapshot">
+ <refentryinfo>
+ <title>systemd.snapshot</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd.snapshot</refentrytitle>
+ <manvolnum>5</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd.snapshot</refname>
+ <refpurpose>systemd snapshot units</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <para><filename>systemd.snapshot</filename></para>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para>Snapshot units are not configured via unit
+ configuration files. Nonetheless they are named
+ similar to filenames. A unit name whose name ends in
+ <filename>.snapshot</filename> refers to a dynamic
+ snapshot of the systemd runtime state.</para>
+
+ <para>Snapshots are not configured on disk but created
+ dynamically via <command>systemctl snapshot</command>
+ (see
+ <citerefentry><refentrytitle>systemctl</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+ for details) or an equivalent command. When created
+ they will automatically get dependencies on the
+ currently activated units. They hence act as saved
+ runtime state of the systemd manager. Later on the
+ user may choose to return to the saved state via
+ <command>systemctl isolate</command>. They are hence
+ useful to roll back to a defined state after
+ temporarily starting/stopping services or
+ similar.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemctl</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemd.unit</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/systemd.unit.xml b/man/systemd.unit.xml
index da077e209..df8761391 100644
--- a/man/systemd.unit.xml
+++ b/man/systemd.unit.xml
@@ -151,10 +151,13 @@
with the device node <filename>/dev/sda</filename> in
the file system namespace. If this applies a special
way to escape the path name is used, so that it is
- usable as part of a file name. Basically, given a path,
- "/" is replaced by "-", and all unprintable characters
- and the "-" are replaced by C-style "\x20"
- escapes. This escaping is reversible.</para>
+ usable as part of a file name. Basically, given a
+ path, "/" is replaced by "-", and all unprintable
+ characters and the "-" are replaced by C-style "\x20"
+ escapes. The root directory "/" is encoded as single
+ dash, while otherwise the initial and ending "/" is
+ removed from all paths during transformation. This
+ escaping is reversible.</para>
<para>Optionally, units may be instantiated from a
template file at runtime. This allows creation of