summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/systemd/meson.build1
-rw-r--r--src/systemd/sd-messages.h4
2 files changed, 5 insertions, 0 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index 82159f336..8530f7fd2 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -21,6 +21,7 @@ _systemd_headers = '''
sd-login.h
sd-messages.h
'''.split()
+#endif // 0
# https://github.com/mesonbuild/meson/issues/1633
systemd_headers = files(_systemd_headers)
diff --git a/src/systemd/sd-messages.h b/src/systemd/sd-messages.h
index f466d9b06..4bc248a4b 100644
--- a/src/systemd/sd-messages.h
+++ b/src/systemd/sd-messages.h
@@ -99,6 +99,10 @@ _SD_BEGIN_DECLARATIONS;
#define SD_MESSAGE_UNIT_RELOADED SD_ID128_MAKE(7b,05,eb,c6,68,38,42,22,ba,a8,88,11,79,cf,da,54)
#define SD_MESSAGE_UNIT_RELOADED_STR SD_ID128_MAKE_STR(7b,05,eb,c6,68,38,42,22,ba,a8,88,11,79,cf,da,54)
+#define SD_MESSAGE_UNIT_RESTART_SCHEDULED SD_ID128_MAKE(5e,b0,34,94,b6,58,48,70,a5,36,b3,37,29,08,09,b3)
+#define SD_MESSAGE_UNIT_RESTART_SCHEDULED_STR \
+ SD_ID128_MAKE_STR(5e,b0,34,94,b6,58,48,70,a5,36,b3,37,29,08,09,b3)
+
#define SD_MESSAGE_SPAWN_FAILED SD_ID128_MAKE(64,12,57,65,1c,1b,4e,c9,a8,62,4d,7a,40,a9,e1,e7)
#define SD_MESSAGE_SPAWN_FAILED_STR SD_ID128_MAKE_STR(64,12,57,65,1c,1b,4e,c9,a8,62,4d,7a,40,a9,e1,e7)