summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--Makefile-man.am2
-rw-r--r--Makefile.am10
-rw-r--r--TODO8
-rw-r--r--man/systemd-saproxy.xml (renamed from man/systemd-sabridge.xml)26
-rw-r--r--src/saproxy/Makefile (renamed from src/sabridge/Makefile)0
-rw-r--r--src/saproxy/saproxy.c (renamed from src/sabridge/sabridge.c)4
7 files changed, 26 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
index d2d5da58f..22485b42d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -71,7 +71,7 @@
/systemd-reply-password
/systemd-rfkill
/systemd-run
-/systemd-sabridge
+/systemd-saproxy
/systemd-shutdown
/systemd-shutdownd
/systemd-sleep
diff --git a/Makefile-man.am b/Makefile-man.am
index e78a8a21e..6b286bc48 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -66,7 +66,7 @@ MANPAGES += \
man/systemd-nspawn.1 \
man/systemd-remount-fs.service.8 \
man/systemd-run.1 \
- man/systemd-sabridge.1 \
+ man/systemd-saproxy.1 \
man/systemd-shutdownd.service.8 \
man/systemd-sleep.conf.5 \
man/systemd-suspend.service.8 \
diff --git a/Makefile.am b/Makefile.am
index 287718413..59c517426 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -300,7 +300,7 @@ bin_PROGRAMS = \
systemd-delta \
systemd-analyze \
systemd-run \
- systemd-sabridge
+ systemd-saproxy
dist_bin_SCRIPTS = \
src/kernel-install/kernel-install
@@ -3210,10 +3210,10 @@ EXTRA_DIST += \
# ------------------------------------------------------------------------------
-systemd_sabridge_SOURCES = \
- src/sabridge/sabridge.c
+systemd_saproxy_SOURCES = \
+ src/saproxy/saproxy.c
-systemd_sabridge_LDADD = \
+systemd_saproxy_LDADD = \
libsystemd-shared.la \
libsystemd-logs.la \
libsystemd-journal-internal.la \
@@ -3221,7 +3221,7 @@ systemd_sabridge_LDADD = \
libsystemd-daemon.la \
libsystemd-bus.la
-systemd_sabridge_CFLAGS = \
+systemd_saproxy_CFLAGS = \
$(AM_CFLAGS)
# ------------------------------------------------------------------------------
diff --git a/TODO b/TODO
index a047f626e..a3ab09e50 100644
--- a/TODO
+++ b/TODO
@@ -48,13 +48,13 @@ CGroup Rework Completion:
Features:
-* sabridge: Support multiple inherited sockets mapped using different proxies
+* saproxy: Support multiple inherited sockets mapped using different proxies
-* sabridge: Use a nonblocking alternative to getaddrinfo
+* saproxy: Use a nonblocking alternative to getaddrinfo
-* sabridge: Until we can start daemons directly, find a less ugly, less racy alternative than shell scripts for the second man page example.
+* saproxy: Until we can start daemons directly, find a less ugly, less racy alternative than shell scripts for the second man page example.
-* sabridge: Support starting daemons directly without requiring a shell script; update man pages
+* saproxy: Support starting daemons directly without requiring a shell script; update man pages
* "systemctl cat" or "systemctl view" command or or so, that cats the backing unit file of a service, plus its drop-ins and shows them in a pager
diff --git a/man/systemd-sabridge.xml b/man/systemd-saproxy.xml
index abeb1a5a4..1314b3173 100644
--- a/man/systemd-sabridge.xml
+++ b/man/systemd-saproxy.xml
@@ -20,9 +20,9 @@
You should have received a copy of the GNU Lesser General Public License
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="systemd-sabridge">
+<refentry id="systemd-saproxy">
<refentryinfo>
- <title>systemd-sabridge</title>
+ <title>systemd-saproxy</title>
<productname>systemd</productname>
<authorgroup>
<author>
@@ -34,23 +34,23 @@
</authorgroup>
</refentryinfo>
<refmeta>
- <refentrytitle>systemd-sabridge</refentrytitle>
+ <refentrytitle>systemd-saproxy</refentrytitle>
<manvolnum>1</manvolnum>
</refmeta>
<refnamediv>
- <refname>systemd-sabridge</refname>
+ <refname>systemd-saproxy</refname>
<refpurpose>Inherit a socket. Bidirectionally
proxy.</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
- <command>systemd-sabridge</command>
+ <command>systemd-saproxy</command>
<arg choice="opt" rep="repeat">OPTIONS</arg>
<arg choice="plain"><replaceable>HOSTNAME-OR-IP</replaceable></arg>
<arg choice="plain"><replaceable>PORT-OR-SERVICE</replaceable></arg>
</cmdsynopsis>
<cmdsynopsis>
- <command>systemd-sabridge</command>
+ <command>systemd-saproxy</command>
<arg choice="opt" rep="repeat">OPTIONS</arg>
<arg choice="plain"><replaceable>UNIX-DOMAIN-SOCKET-PATH</replaceable>
</arg>
@@ -59,7 +59,7 @@
<refsect1>
<title>Description</title>
<para>
- <command>systemd-sabridge</command>provides a proxy
+ <command>systemd-saproxy</command>provides a proxy
to socket-activate services that do not yet support
native socket activation. On behalf of the daemon,
the proxy inherits the socket from systemd, accepts
@@ -68,7 +68,7 @@
data between the two.</para>
<para>This utility's behavior is similar to
<citerefentry><refentrytitle>socat</refentrytitle><manvolnum>1</manvolnum> </citerefentry>.
- The main differences for <command>systemd-sabridge</command>
+ The main differences for <command>systemd-saproxy</command>
are support for socket activation with
<literal>Accept=false</literal> and an event-driven
design that scales better with the number of
@@ -102,7 +102,7 @@
invoked indirectly, for
example with a shell script
rather than with
- <option>ExecStart=/usr/bin/systemd-sabridge</option>
+ <option>ExecStart=/usr/bin/systemd-saproxy</option>
</para>
</listitem>
</varlistentry>
@@ -137,7 +137,7 @@ After=nginx.service
Requires=nginx.service
[Service]
-ExecStart=/usr/bin/systemd-sabridge /tmp/nginx.sock
+ExecStart=/usr/bin/systemd-saproxy /tmp/nginx.sock
PrivateTmp=true
PrivateNetwork=true]]>
</programlisting>
@@ -190,14 +190,14 @@ After=syslog.target remote-fs.target nss-lookup.target
[Service]
ExecStartPre=/usr/sbin/nginx -t
-ExecStart=/usr/bin/sabridge-nginx.sh
+ExecStart=/usr/bin/saproxy-nginx.sh
PrivateTmp=true
PrivateNetwork=true]]>
</programlisting>
</example>
<example label="shell script">
<title>
- /usr/bin/sabridge-nginx.sh</title>
+ /usr/bin/saproxy-nginx.sh</title>
<programlisting>
<![CDATA[#!/bin/sh
/usr/sbin/nginx
@@ -205,7 +205,7 @@ while [ ! -f /tmp/nginx.pid ]
do
/usr/bin/inotifywait /tmp/nginx.pid
done
-/usr/bin/systemd-sabridge --ignore-env localhost 8080]]>
+/usr/bin/systemd-saproxy --ignore-env localhost 8080]]>
</programlisting>
</example>
<example label="nginx configuration">
diff --git a/src/sabridge/Makefile b/src/saproxy/Makefile
index 9d0750519..9d0750519 100644
--- a/src/sabridge/Makefile
+++ b/src/saproxy/Makefile
diff --git a/src/sabridge/sabridge.c b/src/saproxy/saproxy.c
index 058987187..ca75b400b 100644
--- a/src/sabridge/sabridge.c
+++ b/src/saproxy/saproxy.c
@@ -448,7 +448,7 @@ static int help(void) {
}
static void version(void) {
- puts(PACKAGE_STRING " sabridge");
+ puts(PACKAGE_STRING " saproxy");
}
static int parse_argv(int argc, char *argv[], struct proxy *p) {
@@ -561,7 +561,7 @@ int main(int argc, char *argv[]) {
goto finish;
}
- log_info("Starting the socket activation bridge with listener fd=%d.", p.listen_fd);
+ log_info("Starting the socket activation proxy with listener fd=%d.", p.listen_fd);
r = run_main_loop(&p);
if (r < 0) {