summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am10
-rw-r--r--units/.gitignore1
-rw-r--r--units/systemd-ask-password-plymouth.path13
-rw-r--r--units/systemd-ask-password-plymouth.service.in12
4 files changed, 33 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a55b244b6..7f8df05da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -210,7 +210,8 @@ dist_systemunit_DATA = \
units/systemd-readahead-done.timer \
units/systemd-tmpfiles-clean.timer \
units/quotaon.service \
- units/systemd-ask-password-wall.path
+ units/systemd-ask-password-wall.path \
+ units/systemd-ask-password-plymouth.path
nodist_systemunit_DATA = \
units/sysinit.target \
@@ -237,6 +238,7 @@ nodist_systemunit_DATA = \
units/systemd-tmpfiles-clean.service \
units/systemd-user-sessions.service \
units/systemd-ask-password-wall.service \
+ units/systemd-ask-password-plymouth.service \
units/syslog.target \
units/halt.service \
units/poweroff.service \
@@ -279,6 +281,7 @@ EXTRA_DIST = \
units/systemd-tmpfiles-clean.service.in \
units/systemd-user-sessions.service.in \
units/systemd-ask-password-wall.service.in \
+ units/systemd-ask-password-plymouth.service.in \
units/syslog.target.in \
units/halt.service.in \
units/poweroff.service.in \
@@ -1186,8 +1189,9 @@ if TARGET_FEDORA
rm -f single.service && \
$(LN_S) $(systemunitdir)/single.service single.service )
( cd $(DESTDIR)$(systemunitdir)/multi-user.target.wants && \
- rm -f plymouth-quit.service && \
- $(LN_S) ../plymouth-quit.service plymouth-quit.service )
+ rm -f plymouth-quit.service systemd-ask-password-plymouth.path && \
+ $(LN_S) ../plymouth-quit.service plymouth-quit.service && \
+ $(LN_S) ../systemd-ask-password-plymouth.path systemd-ask-password-plymouth.path )
( cd $(DESTDIR)$(systemunitdir)/reboot.target.wants && \
rm -f plymouth-reboot.service && \
$(LN_S) ../plymouth-reboot.service plymouth-reboot.service )
diff --git a/units/.gitignore b/units/.gitignore
index 42058c501..add0c6b82 100644
--- a/units/.gitignore
+++ b/units/.gitignore
@@ -1,3 +1,4 @@
+systemd-ask-password-plymouth.service
systemd-ask-password-wall.service
quotacheck.service
fsck@.service
diff --git a/units/systemd-ask-password-plymouth.path b/units/systemd-ask-password-plymouth.path
new file mode 100644
index 000000000..9fd51f2ee
--- /dev/null
+++ b/units/systemd-ask-password-plymouth.path
@@ -0,0 +1,13 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Forward Password Requests to Plymouth Directory Watch
+After=local-fs.target
+
+[Path]
+DirectoryNotEmpty=/dev/.systemd/ask-password
diff --git a/units/systemd-ask-password-plymouth.service.in b/units/systemd-ask-password-plymouth.service.in
new file mode 100644
index 000000000..3cd9b7fe7
--- /dev/null
+++ b/units/systemd-ask-password-plymouth.service.in
@@ -0,0 +1,12 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Forward Password Requests to Plymouth
+
+[Service]
+ExecStart=@rootbindir@/systemd-tty-ask-password-agent --watch --plymouth