summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--TODO8
-rw-r--r--units/sys-kernel-config.mount1
-rw-r--r--units/sys-kernel-debug.automount15
-rw-r--r--units/sys-kernel-debug.mount2
5 files changed, 9 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index de6325d4a..ad21f681e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,7 +362,6 @@ dist_systemunit_DATA = \
units/dev-mqueue.automount \
units/dev-mqueue.mount \
units/sys-kernel-config.mount \
- units/sys-kernel-debug.automount \
units/sys-kernel-debug.mount \
units/sys-kernel-security.automount \
units/sys-kernel-security.mount \
@@ -1842,7 +1841,7 @@ endif
rm -f dev-hugepages.automount \
dev-mqueue.automount \
sys-kernel-config.mount \
- sys-kernel-debug.automount \
+ sys-kernel-debug.mount \
sys-kernel-security.automount \
systemd-vconsole-setup.service \
systemd-modules-load.service \
@@ -1855,7 +1854,7 @@ endif
$(LN_S) ../dev-hugepages.automount dev-hugepages.automount && \
$(LN_S) ../dev-mqueue.automount dev-mqueue.automount && \
$(LN_S) ../sys-kernel-config.mount sys-kernel-config.mount && \
- $(LN_S) ../sys-kernel-debug.automount sys-kernel-debug.automount && \
+ $(LN_S) ../sys-kernel-debug.mount sys-kernel-debug.mount && \
$(LN_S) ../sys-kernel-security.automount sys-kernel-security.automount && \
$(LN_S) ../systemd-vconsole-setup.service systemd-vconsole-setup.service && \
$(LN_S) ../systemd-modules-load.service systemd-modules-load.service && \
diff --git a/TODO b/TODO
index 123e96195..889036051 100644
--- a/TODO
+++ b/TODO
@@ -16,11 +16,11 @@ Features:
* File systems:
mqueue - boot
- configfs module boot (order after module load)
+ configfs module boot (order after module load) GOOD
securityfs - boot
- binfmt_misc module autofs
- fuse module udev
- debug - boot
+ binfmt_misc module autofs GOOD
+ fuse module udev GOOD
+ debug - boot GOOD
hugepages - boot
* introduce sd_log_open() to create a connection to the syslog bridge via sd-daemon.h
diff --git a/units/sys-kernel-config.mount b/units/sys-kernel-config.mount
index f64b1ac25..d6862bf6b 100644
--- a/units/sys-kernel-config.mount
+++ b/units/sys-kernel-config.mount
@@ -10,6 +10,7 @@ Description=Configuration File System
DefaultDependencies=no
ConditionPathExists=/sys/kernel/config
After=systemd-modules-load.service
+Before=sysinit.target
[Mount]
What=configfs
diff --git a/units/sys-kernel-debug.automount b/units/sys-kernel-debug.automount
deleted file mode 100644
index 2f2de9829..000000000
--- a/units/sys-kernel-debug.automount
+++ /dev/null
@@ -1,15 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Debug File System Automount Point
-DefaultDependencies=no
-Before=sysinit.target
-ConditionPathExists=/sys/kernel/debug
-
-[Automount]
-Where=/sys/kernel/debug
diff --git a/units/sys-kernel-debug.mount b/units/sys-kernel-debug.mount
index 53d107260..d9fca1ff3 100644
--- a/units/sys-kernel-debug.mount
+++ b/units/sys-kernel-debug.mount
@@ -8,6 +8,8 @@
[Unit]
Description=Debug File System
DefaultDependencies=no
+ConditionPathExists=/sys/kernel/debug
+Before=sysinit.target
[Mount]
What=debugfs