summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am21
-rw-r--r--man/vconsole.conf.xml4
-rw-r--r--src/vconsole/vconsole-setup.c5
3 files changed, 10 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index 683685192..acc8f8770 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,43 +160,36 @@ AM_LDFLAGS = $(OUR_LDFLAGS)
if TARGET_GENTOO
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/usr/bin/setfont\"
else
if TARGET_ARCH
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/usr/bin/setfont\"
else
if TARGET_FRUGALWARE
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/usr/bin/setfont\"
else
if TARGET_MANDRIVA
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/bin/setfont\"
else
if TARGET_ANGSTROM
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/usr/bin/setfont\"
else
if TARGET_MAGEIA
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
+ -DKBD_SETFONT=\"/bin/setfont\"
else
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\" \
- -DDEFAULT_FONT=\"latarcyrheb-sun16\"
+ -DKBD_SETFONT=\"/bin/setfont\"
endif
endif
endif
diff --git a/man/vconsole.conf.xml b/man/vconsole.conf.xml
index e23a98023..258c82bc6 100644
--- a/man/vconsole.conf.xml
+++ b/man/vconsole.conf.xml
@@ -112,9 +112,7 @@
<listitem><para>Configures the console
font, the console map and the unicode
- font map. <varname>FONT=</varname>
- defaults to
- <literal>latarcyrheb-sun16</literal>.</para></listitem>
+ font map.</para></listitem>
</varlistentry>
</variablelist>
diff --git a/src/vconsole/vconsole-setup.c b/src/vconsole/vconsole-setup.c
index 62d9c8d7b..1227b041d 100644
--- a/src/vconsole/vconsole-setup.c
+++ b/src/vconsole/vconsole-setup.c
@@ -215,10 +215,9 @@ int main(int argc, char **argv) {
utf8 = is_locale_utf8();
vc_keymap = strdup("us");
- vc_font = strdup(DEFAULT_FONT);
- if (!vc_keymap || !vc_font) {
- log_error("Failed to allocate strings.");
+ if (!vc_keymap) {
+ log_error("Failed to allocate string.");
goto finish;
}