summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe680b0d9..a9ee8b070 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -843,6 +843,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/ring.h \
src/shared/barrier.c \
src/shared/barrier.h \
+ src/shared/pty.c \
+ src/shared/pty.h \
src/shared/async.c \
src/shared/async.h \
src/shared/copy.c \
@@ -1252,6 +1254,7 @@ tests += \
test-util \
test-ring \
test-barrier \
+ test-pty \
test-tmpfiles \
test-namespace \
test-date \
@@ -1428,6 +1431,12 @@ test_barrier_SOURCES = \
test_barrier_LDADD = \
libsystemd-core.la
+test_pty_SOURCES = \
+ src/test/test-pty.c
+
+test_pty_LDADD = \
+ libsystemd-core.la
+
test_tmpfiles_SOURCES = \
src/test/test-tmpfiles.c