summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 6 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index ed6c307c9..9c7267b06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -682,22 +682,10 @@ CLEANFILES += \
${XML_FILES:.xml=.html}
if HAVE_PYTHON
-noinst_DATA += \
- man/index.html
-
-CLEANFILES += \
- man/index.html
-
-man/index.html: make-man-index.py $(XML_FILES)
- $(AM_V_at)$(MKDIR_P) $(dir $@)
- $(AM_V_GEN)$(PYTHON) $^ > $@
-
MANPAGES += \
+ man/systemd.index.7 \
man/systemd.directives.7
-EXTRA_DIST += \
- man/index.html
-
XML_DIRECTIVE_FILES = \
man/systemd.xml \
man/systemd.unit.xml \
@@ -718,11 +706,16 @@ XML_DIRECTIVE_FILES = \
man/systemd.time.xml \
man/bootchart.conf.xml
+man/systemd.index.xml: make-man-index.py $(filter-out man/systemd.index.xml,$(XML_FILES))
+ $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_GEN)$(PYTHON) $^ > $@
+
man/systemd.directives.xml: make-directive-index.py $(XML_DIRECTIVE_FILES)
$(AM_V_at)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)$(PYTHON) $^ > $@
EXTRA_DIST += \
+ man/systemd.index.xml \
man/systemd.directives.xml
endif