summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index df552e3a0..8d3d45137 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3847,14 +3847,12 @@ loginctl_SOURCES = \
src/login/loginctl.c \
src/login/sysfs-show.c
-loginctl_CFLAGS = \
- $(AM_CFLAGS) \
- $(DBUS_CFLAGS)
-
loginctl_LDADD = \
- libsystemd-dbus.la \
+ libsystemd-bus-internal.la \
libudev-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ libsystemd-id128-internal.la \
+ libsystemd-daemon-internal.la
rootbin_PROGRAMS += \
loginctl