summaryrefslogtreecommitdiff
path: root/shell-completion/zsh
diff options
context:
space:
mode:
Diffstat (limited to 'shell-completion/zsh')
-rw-r--r--shell-completion/zsh/.gitignore1
l---------shell-completion/zsh/Makefile1
-rw-r--r--shell-completion/zsh/_elogind-inhibit1
-rw-r--r--shell-completion/zsh/_loginctl1
-rw-r--r--shell-completion/zsh/meson.build53
5 files changed, 55 insertions, 2 deletions
diff --git a/shell-completion/zsh/.gitignore b/shell-completion/zsh/.gitignore
deleted file mode 100644
index 75f13ad6d..000000000
--- a/shell-completion/zsh/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-/_systemctl
diff --git a/shell-completion/zsh/Makefile b/shell-completion/zsh/Makefile
deleted file mode 120000
index d0b0e8e00..000000000
--- a/shell-completion/zsh/Makefile
+++ /dev/null
@@ -1 +0,0 @@
-../Makefile \ No newline at end of file
diff --git a/shell-completion/zsh/_elogind-inhibit b/shell-completion/zsh/_elogind-inhibit
index 1b3247b2c..764713e28 100644
--- a/shell-completion/zsh/_elogind-inhibit
+++ b/shell-completion/zsh/_elogind-inhibit
@@ -1,4 +1,5 @@
#compdef systemd-inhibit
+# SPDX-License-Identifier: LGPL-2.1+
_systemd_inhibit_command(){
if (( CURRENT == 1 )); then
diff --git a/shell-completion/zsh/_loginctl b/shell-completion/zsh/_loginctl
index 6f6ff6e31..03dde9a89 100644
--- a/shell-completion/zsh/_loginctl
+++ b/shell-completion/zsh/_loginctl
@@ -1,4 +1,5 @@
#compdef loginctl
+# SPDX-License-Identifier: LGPL-2.1+
_loginctl_all_sessions() {
local session description
diff --git a/shell-completion/zsh/meson.build b/shell-completion/zsh/meson.build
new file mode 100644
index 000000000..806ea8850
--- /dev/null
+++ b/shell-completion/zsh/meson.build
@@ -0,0 +1,53 @@
+# SPDX-License-Identifier: LGPL-2.1+
+
+zshcompletiondir = get_option('zshcompletiondir')
+if zshcompletiondir == ''
+ zshcompletiondir = join_paths(datadir, 'zsh/site-functions')
+
+ message('zsh completions: @0@'.format(zshcompletiondir))
+endif
+
+if zshcompletiondir != 'no'
+#if 0 /// elogind has a *very* short list for this...
+# zsh_systemctl = configure_file(
+# input : '_systemctl.in',
+# output : '_systemctl',
+# configuration : substs)
+#
+# items = [['_busctl', ''],
+# ['_journalctl', ''],
+# ['_systemd-analyze', ''],
+# ['_systemd-delta', ''],
+# ['_systemd-nspawn', ''],
+# ['_systemd', ''],
+# ['_systemd-run', ''],
+# ['_udevadm', ''],
+# ['_kernel-install', ''],
+# ['_sd_hosts_or_user_at_host', ''],
+# ['_sd_outputmodes', ''],
+# ['_sd_unit_files', ''],
+# ['_sd_machines', ''],
+# [zsh_systemctl, ''],
+# ['_bootctl', 'ENABLE_EFI'],
+# ['_coredumpctl', 'ENABLE_COREDUMP'],
+# ['_hostnamectl', 'ENABLE_HOSTNAMED'],
+# ['_localectl', 'ENABLE_LOCALED'],
+# ['_loginctl', 'ENABLE_LOGIND'],
+# ['_machinectl', 'ENABLE_MACHINED'],
+# ['_networkctl', 'ENABLE_NETWORKD'],
+# ['_systemd-inhibit', 'ENABLE_LOGIND'],
+# ['_systemd-resolve', 'ENABLE_RESOLVE'],
+# ['_systemd-tmpfiles', 'ENABLE_TMPFILES'],
+# ['_timedatectl', 'ENABLE_TIMEDATED'],
+#else
+ items = [['_loginctl', ''],
+#endif // 0
+ ]
+
+ foreach item : items
+ if item[1] == '' or conf.get(item[1]) == 1
+ install_data(item[0],
+ install_dir : zshcompletiondir)
+ endif
+ endforeach
+endif