summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/basic/meson.build7
-rw-r--r--src/shared/meson.build12
2 files changed, 11 insertions, 8 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index bc7e78655..5eef906d4 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -164,6 +164,7 @@
# securebits.h
# selinux-util.c
# selinux-util.h
+# set.c
# set.h
# sigbus.c
# sigbus.h
@@ -459,6 +460,9 @@ foreach item : [['cap', cap_list_txt, 'capability', ''],
endforeach
basic_sources += [missing_h] + generated_gperf_headers
+basic_gcrypt_sources = files(
+ 'gcrypt-util.c',
+ 'gcrypt-util.h')
libbasic = static_library(
'basic',
@@ -479,8 +483,7 @@ libbasic = static_library(
# # unnecessary linking to libgcrypt.
# libbasic_gcrypt = static_library(
# 'basic-gcrypt',
-# 'gcrypt-util.c',
-# 'gcrypt-util.h',
+# basic_gcrypt_sources,
# include_directories : includes,
# dependencies : [libgcrypt],
# c_args : ['-fvisibility=default'])
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 139ecb0ef..a42059c83 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -3,7 +3,7 @@
# Copyright 2017 Zbigniew Jędrzejewski-Szmek
#if 0 /// elogind has a much shorter list
-# shared_sources = '''
+# shared_sources = files('''
# acl-util.h
# acpi-fpdt.c
# acpi-fpdt.h
@@ -105,7 +105,7 @@
# watchdog.c
# watchdog.h
# wireguard-netlink.h
-# '''.split()
+# '''.split())
#else
shared_sources = '''
bus-util.c
@@ -135,20 +135,20 @@ test_tables_h = files('test-tables.h')
shared_sources += [test_tables_h]
if conf.get('HAVE_ACL') == 1
- shared_sources += ['acl-util.c']
+ shared_sources += files('acl-util.c')
endif
if conf.get('ENABLE_UTMP') == 1
- shared_sources += ['utmp-wtmp.c']
+ shared_sources += files('utmp-wtmp.c')
endif
#if 0 /// UNNEEDED by elogind
# if conf.get('HAVE_SECCOMP') == 1
-# shared_sources += ['seccomp-util.c']
+# shared_sources += files('seccomp-util.c')
# endif
#
# if conf.get('HAVE_LIBIPTC') == 1
-# shared_sources += ['firewall-util.c']
+# shared_sources += files('firewall-util.c')
# endif
#endif // 0