summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXiyue Deng <manphiz@gmail.com>2023-08-24 02:29:10 -0700
committerXiyue Deng <manphiz@gmail.com>2023-08-24 02:29:10 -0700
commit5d9cc6c42c41086c676c41ccdc9a69a053ef7ce1 (patch)
treed06be4d9cd6274fe39c490c121795b7a8f649e15
parent46c845abddd21ced77cb9ba86609e11eb7131abb (diff)
refresh debian/patches/debian-changes
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/debian-changes27
2 files changed, 13 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 4de0092..fb887b4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,7 +4,9 @@ emacs-buttercup (1.31-1) UNRELEASED; urgency=medium
* Remove myself from Uploaders.
[ Xiyue Deng ]
+ * Team upload.
* New upstream release.
+ * Refresh debian/patches/debian-changes.
-- Xiyue Deng <manphiz@gmail.com> Thu, 24 Aug 2023 01:50:38 -0700
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 7c007d7..5aba7c1 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -15,12 +15,13 @@ upload of upstream version 1.2.3, you could use:
`git clone`.)
A single combined diff, containing all the changes, follows.
---- emacs-buttercup-1.26.orig/README.md
-+++ emacs-buttercup-1.26/README.md
-@@ -1,10 +1,5 @@
+--- emacs-buttercup-1.31.orig/README.md
++++ emacs-buttercup-1.31/README.md
+@@ -1,11 +1,5 @@
# Buttercup — Behavior-Driven Emacs Lisp Testing
-[![Build and test](https://github.com/jorgenschaefer/emacs-buttercup/workflows/Build%20and%20test/badge.svg)](https://github.com/jorgenschaefer/emacs-buttercup/actions?query=workflow%3A%22Build+and+test%22+branch%3Amaster)
+-[![NonGNU ELPA](https://elpa.nongnu.org/nongnu/buttercup.svg)](https://elpa.nongnu.org/nongnu/buttercup.html)
-[![MELPA Stable](http://stable.melpa.org/packages/buttercup-badge.svg)](http://stable.melpa.org/#/buttercup)
-
-![Ranculus repens, photo by sannse](docs/images/buttercup.jpg)
@@ -28,16 +29,7 @@ A single combined diff, containing all the changes, follows.
Buttercup is a behavior-driven development framework for testing Emacs
Lisp code. It allows to group related tests so they can share common
set-up and tear-down code, and allows the programmer to “spy” on
-@@ -16,7 +11,7 @@ The framework is heavily inspired by
-
- ## Example
-
--*Full article: [Writing Tests](docs/writing-tests.md)*
-+*Full article: [Writing Tests](writing-tests.md)*
-
- A simple test looks like this.
-
-@@ -26,26 +21,11 @@ A simple test looks like this.
+@@ -27,30 +21,9 @@ A simple test looks like this.
(expect t :to-be t)))
```
@@ -46,21 +38,24 @@ A single combined diff, containing all the changes, follows.
-*Full article: [Running Tests](docs/running-tests.md)*
-
-You can install buttercup from
+-[NonGNU ELPA](https://elpa.nongnu.org/) or
-[MELPA Stable](http://stable.melpa.org/). Add the following to your
-`init.el` or `.emacs` file:
-
-```
-(require 'package)
+-;; Available as a default in GNU Emacs from version 28.1
+-(add-to-list 'package-archives
+- ("nongnu" . "https://elpa.nongnu.org/nongnu/") t)
-(add-to-list 'package-archives
- '("melpa-stable" . "http://stable.melpa.org/packages/") t)
-```
-
-This should allow you to `M-x package-install RET buttercup RET`.
-+## Usage
-
+-
-Alternatively, users of Debian 9 or later or Ubuntu 16.10 or later may
-simply `apt-get install elpa-buttercup`.
-+*Full article: [Running Tests](running-tests.md)*
++## Usage
-Now create a file called `test-feature.el` with these contents:
+Create a file called `test-feature.el` with these contents: