summaryrefslogtreecommitdiff
path: root/jabber-sawfish.el
diff options
context:
space:
mode:
authorMagnus Henoch <mange@freemail.hu>2008-04-20 06:21:40 +0000
committerKirill A. Korinskiy <catap@catap.ru>2008-04-20 06:21:40 +0000
commitf2405e37e63247b0df867fa756f50b0b5ce5c568 (patch)
tree639393484939c3d0d8ac120fc4c345c5c2e3dbf9 /jabber-sawfish.el
parenta2056a03978453967ad12802fe83a095e65c3352 (diff)
Revision: mange@freemail.hu--2005/emacs-jabber--cvs-head--0--patch-479
Creator: Magnus Henoch <mange@freemail.hu> Merge autotools and test suite Patches applied: * mange@freemail.hu--2005/emacs-jabber--autotools--0--base-0 tag of mange@freemail.hu--2005/emacs-jabber--cvs-head--0--patch-477 * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-1 Add Makefile.am and configure.ac * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-2 Don't require jabber-muc-nick-completion from jabber-alert, but add an autoload * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-3 Require external notifiers from jabber.el, not jabber-alert.el * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-4 External notifiers require jabber-alert when compiling * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-5 Build autoloads * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-6 Break lines in Makefile.am * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-7 Rearrange Makefile.am to avoid circular dependency * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-8 Remove unnecessary BUILT_SOURCES * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-9 Add jabber.texi to Makefile.am * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-10 Maintainer-clean jabber-autoload.el * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-11 Distribute and install xmppuri.sh * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-12 Create zip file too * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-13 Remove explicit autoloads from jabber.el; add corresponding cookies * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-14 Merge CDATA fix * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-15 Add comment explaining double-compilation * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-16 Add test suite * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-17 Use subdirectory makefile for tests * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-18 Distribute tests * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-19 -Wall and -Werror for automake * mange@freemail.hu--2005/emacs-jabber--autotools--0--patch-20 Use makefile variables instead of autoconf ones
Diffstat (limited to 'jabber-sawfish.el')
-rw-r--r--jabber-sawfish.el2
1 files changed, 2 insertions, 0 deletions
diff --git a/jabber-sawfish.el b/jabber-sawfish.el
index 6da7ed3..15546f5 100644
--- a/jabber-sawfish.el
+++ b/jabber-sawfish.el
@@ -18,6 +18,8 @@
;; along with this program; if not, write to the Free Software
;; Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+(eval-when-compile (require 'jabber-alert))
+
(defcustom jabber-sawfish-display-time 3
"Time in seconds for displaying a jabber message through the
Sawfish window manager."