summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRémi Vanicat <vanicat@debian.org>2019-07-31 10:11:11 +0200
committerRémi Vanicat <vanicat@debian.org>2019-07-31 10:11:11 +0200
commitda63fbb4e2286bee86e1c6f99b8aaff60556dc19 (patch)
treed6fac6dc246dc7afc1646a372cec2af68d2014d0 /Makefile
parent6203143c80d0b19676eae952744101190d77ba2f (diff)
parentb344cd6d3036d64c205737263cb5c2cebd6301ca (diff)
Update upstream source from tag 'upstream/1.0'
Update to upstream version '1.0' with Debian dir 6db6ffdb0d58ba6dee3952f9a281a561d5d51723
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 91e6b00..55cb555 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,19 @@
+EMACS ?= emacs
+# Handle the mess when inside Emacs.
+unexport INSIDE_EMACS #cask not like this.
+ifeq ($(EMACS), t)
+EMACS = emacs
+endif
+
+emacs = $(EMACS)
all: package
+byte-compile:
+ cask exec $(emacs) --batch -L lisp -f batch-byte-compile *.el
+
package:
cask package
clean:
rm -rf dist
rm -f -- *.elc
-