summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormattdangerw <mattdangerw@gmail.com>2013-09-09 13:32:09 -0700
committermattdangerw <mattdangerw@gmail.com>2013-09-09 13:32:09 -0700
commit386eb5dfcd5053ab0e8989a9233a25e89c6a5abf (patch)
tree36d66a76a002fb6c420a084766fb6a36ab97092b
parent5424131d601b10d14d5e0293cc42677fe8bebb8e (diff)
parent131798705325db7959243adfc1b5a7f96aeb35ce (diff)
Merge pull request #294 from endlessm/issues/122
Use Automake's parallel test harness
-rw-r--r--.gitignore3
-rw-r--r--Makefile.am5
-rwxr-xr-xautogen.sh9
-rw-r--r--configure.ac9
-rw-r--r--docs/reference/endless/Makefile.am17
5 files changed, 18 insertions, 25 deletions
diff --git a/.gitignore b/.gitignore
index 34c39f5..bc86caf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -117,7 +117,8 @@ pip-log.txt
.coverage
.tox
nosetests.xml
-test-results.xml
+*.log
+gtkdoc-test-dummy-file*
# Translations
*.mo
diff --git a/Makefile.am b/Makefile.am
index f7d41d7..740e07e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,7 +156,6 @@ m4_DATA = \
include $(top_srcdir)/test/Makefile.am
# Run tests when running 'make check'
-TESTS_ENVIRONMENT = gtester -k -o test-results.xml --verbose
TESTS = test/run-tests
-
-CLEANFILES += test-results.xml
+LOG_COMPILER = gtester
+AM_LOG_FLAGS = -k --verbose
diff --git a/autogen.sh b/autogen.sh
index 9a98233..6c20886 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -32,15 +32,6 @@ if test -z "$NOCONFIGURE"; then
echo "environment."
fi
-am_ver=`automake --version | grep -m 1 -o '[^ ]*$'`
-# Autmake 1.11.x doesn't grasp the 'serial-tests' option. Add a m4 file which
-# defines HAS_SERIAL_TESTS_OPTION so we can keep our configure.ac forward
-# compatible
-case $am_ver in
- 1.11*|1.12*) echo '';;
- *) echo 'm4_define([HAS_SERIAL_TESTS_OPTION], [1])';;
-esac > m4/serial-tests.m4
-
# Run the actual tools to prepare the clean checkout
gtkdocize || exit $?
autoreconf -fi || exit $?
diff --git a/configure.ac b/configure.ac
index 028360a..eb450a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,12 +36,9 @@ AC_INIT([Open Endless SDK], [_EOS_SDK_VERSION_MACRO],
dnl AC_CONFIG_SRCDIR([src/hello.c])
# Initialize Automake: enable all warnings and do not insist on GNU standards
# no-portability suppresses warnings about syntax specific to GNU make
-# If Automake >= 1.13 we need the serial-tests options
-# We use an serial-test.m4 file set up in autogen.sh to test if we need it
-m4_include([m4/serial-tests.m4])
-m4_ifdef([HAS_SERIAL_TESTS_OPTION],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 serial-tests])],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11])])
+# parallel-tests specifies that we use the new parallel-running test harness.
+# Unlike serial-tests, this option is accepted by Automake 1.11
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index 7131b0c..abcc0f9 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -86,12 +86,17 @@ EXTRA_DIST +=
# for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
#DISTCLEANFILES +=
-# Comment this out if you want 'make check' to test you doc status
-# and run some sanity checks
if ENABLE_GTK_DOC
-TESTS_ENVIRONMENT = cd $(srcdir) && \
- DOC_MODULE=$(DOC_MODULE) DOC_MAIN_SGML_FILE=$(DOC_MAIN_SGML_FILE) \
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir)
-TESTS = $(GTKDOC_CHECK)
+AM_TESTS_ENVIRONMENT = \
+ export DOC_MODULE=$(DOC_MODULE); \
+ export DOC_MAIN_SGML_FILE=$(DOC_MAIN_SGML_FILE); \
+ export SRCDIR=$(abs_srcdir); \
+ export BUILDDIR=$(abs_builddir)
+TESTS = gtkdoc-test-dummy-file
+LOG_COMPILER = cd $(srcdir) && $(GTKDOC_CHECK)
+
+# Need a dummy file to feed to GTKDOC_CHECK in the parallel test harness
+gtkdoc-test-dummy-file:
+ $(AM_V_GEN)touch $@
endif