summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2017-08-29 18:12:51 -0700
committerPhilip Chimento <philip@endlessm.com>2017-08-29 18:12:51 -0700
commit5f2aa7fb5e588c589742aeacec391d0787a4cf3d (patch)
tree126671f771d479b09c64ea356ed15d1047e9f361
parente3a78f363ca228f0ce85eaf12ee5abe114e4ded5 (diff)
test: Don't connect to accessibility
Run tests with NO_AT_BRIDGE=1 so that they don't fail when there is no accessibility service. https://phabricator.endlessm.com/T18981
-rw-r--r--test/Makefile.am.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 970f517..f4b1c6a 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -87,6 +87,7 @@ CLEANFILES += stderr.log
# directory with junk from the tests
TESTS_ENVIRONMENT = \
export EOS_DISABLE_METRICS=1; \
+ export NO_AT_BRIDGE=1; \
export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \