summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-04-17 13:24:39 -0700
committerPhilip Chimento <philip@endlessm.com>2015-04-17 15:34:19 -0700
commitd37251d6e005f3b965d9c08b1476c98731b0ffee (patch)
tree69544125fc5bc53929270c0da1715a56be38ce20
parenta7ec9a08a19c80ed48aacabff8fa330d70800574 (diff)
Address warning about rule being overwritten
There are two dist-hook rules, so a double-colon rule is appropriate. That means both will get executed when required, instead of only one. [endlessm/eos-sdk#3054]
-rw-r--r--Makefile.am4
-rw-r--r--docs/reference/webhelper/Makefile.am.inc2
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e3aa02..467f047 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,9 +33,9 @@ DISTCLEANFILES =
# Make sure that 'make dist' includes documentation
if CAN_MAKE_DIST
-dist-hook:
+dist-hook::
else
-dist-hook:
+dist-hook::
@echo "***"
@echo "*** You must configure with --enable-gtk-doc, --enable-gir-doc, and"
@echo "*** --enable-js-doc to run make dist or make distcheck."
diff --git a/docs/reference/webhelper/Makefile.am.inc b/docs/reference/webhelper/Makefile.am.inc
index 3b47e19..55caccf 100644
--- a/docs/reference/webhelper/Makefile.am.inc
+++ b/docs/reference/webhelper/Makefile.am.inc
@@ -24,7 +24,7 @@ DISTCLEANFILES += \
distclean-local:
@rm -rf docs/reference/webhelper/html
-dist-hook:
+dist-hook::
@mkdir -p $(distdir)/docs/reference/webhelper/html
@cp -r docs/reference/webhelper/html/* $(distdir)/docs/reference/webhelper/html