summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatt Watson <mattdangerw@gmail.com>2013-04-25 15:43:51 -0700
committerP. F. Chimento <philip.chimento@gmail.com>2013-05-16 12:17:09 +0200
commit2ca816baa7d8dd68b522fd43fe0539edb63890a1 (patch)
treef71395843774a54fea3aa02d8c2650aa167121cd /Makefile.am
parentab5921b74431197b63f8b4be432560c9e01b7425 (diff)
Added --warn-all flag to g-ir-scanner call.
Warns about any non introspectable functions in the public API.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b04dad6..1fcb096 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,7 @@ DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-include $(INTROSPECTION_MAKEFILE)
INTROSPECTION_GIRS =
-INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
+INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir) --warn-all
INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
if HAVE_INTROSPECTION