summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-05-19 11:31:25 -0700
committerPhilip Chimento <philip@endlessm.com>2015-05-21 13:22:23 -0700
commita58f5454c8b046ba4f17534a88db1c19ac22b822 (patch)
treeb25eca159bc2d6f54882e9f29cf0818ad15f9c7b /Makefile.am
parente2729f045a9459c9a320c617ac6e599814744e56 (diff)
Expose gettext() to client-side JS
This exposes the function set by webhelper.set_gettext() to the client- side Javascript as a gettext() function, defined on the global window object. This allows apps to translate messages that are generated at runtime, not just messages in static HTML. Some often-used JavaScriptCore operations can be turned into separate functions, which we can put in a separate source file. This is in anticipation of the next commit where we will define another function property of the global object. [endlessm/eos-sdk#291]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e54fe6..0a918ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,7 +114,11 @@ libwebhelper2private_la_LDFLAGS = -avoid-version
webhelper2extensionsdir = $(libexecdir)/webhelper2
webhelper2extensions_LTLIBRARIES = wh2extension.la
-wh2extension_la_SOURCES = webhelper/webextensions/wh2extension.c
+wh2extension_la_SOURCES = \
+ webhelper/webextensions/wh2extension.c \
+ webhelper/webextensions/wh2jscutil.c \
+ webhelper/webextensions/wh2jscutil.h \
+ $(NULL)
wh2extension_la_CPPFLAGS = @WEBHELPER2_EXTENSION_CFLAGS@
wh2extension_la_LIBADD = @WEBHELPER2_EXTENSION_LIBS@
wh2extension_la_LDFLAGS = -module -avoid-version -no-undefined