summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2013-04-15 18:04:27 +0200
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-24 14:48:15 +0200
commit096c63f7ed002b99a995c35a407483a0bfa161c5 (patch)
treecf324aae1bce4f5cb9edf42e68bc9c7cb4da0964 /configure.ac
parent7fc4090461ad888612491814e5a44aaf7e52d7ff (diff)
Application class
Add an EosApplication class. Functionality: - present main application window when activated - warn if more than one application window is added Also add a stub EosWindow class that overrides GtkWindow's "application" property to be a construct-only property. [#4]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08f32f1..42f4098 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,10 +69,10 @@ AC_SUBST(EOS_SDK_LT_VERSION_INFO)
# Required versions of libraries
# Update these whenever you use a function that requires a certain API version
-GLIB_REQUIREMENT="glib-2.0 >= 2.20"
+GLIB_REQUIREMENT="glib-2.0 >= 2.36"
GOBJECT_REQUIREMENT="gobject-2.0"
GIO_REQUIREMENT="gio-2.0"
-GTK_REQUIREMENT="gtk+-3.0 >= 3.0"
+GTK_REQUIREMENT="gtk+-3.0 >= 3.4"
# These go into the pkg-config file as Requires: and Requires.private:
# (Generally, use Requires.private: instead of Requires:)
EOS_REQUIRED_MODULES=