summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:01 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:44 -0700
commit131798705325db7959243adfc1b5a7f96aeb35ce (patch)
tree5eba96212666134c922b7b837f419670b78a7fa9 /configure.ac
parent2444b1473a980e770b9a85f93ecfb75efd97bbed (diff)
Use Automake's parallel test harness
This gets rid of a long-standing workaround and makes it easier to start using a proper test harness for Javascript unit tests. Unfortunately, it requires a workaround to be able to run gtkdoc-check on the documentation, but the workaround is not too bad. [endlessm/eos-sdk#122]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 028360a..eb450a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,12 +36,9 @@ AC_INIT([Open Endless SDK], [_EOS_SDK_VERSION_MACRO],
dnl AC_CONFIG_SRCDIR([src/hello.c])
# Initialize Automake: enable all warnings and do not insist on GNU standards
# no-portability suppresses warnings about syntax specific to GNU make
-# If Automake >= 1.13 we need the serial-tests options
-# We use an serial-test.m4 file set up in autogen.sh to test if we need it
-m4_include([m4/serial-tests.m4])
-m4_ifdef([HAS_SERIAL_TESTS_OPTION],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 serial-tests])],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11])])
+# parallel-tests specifies that we use the new parallel-running test harness.
+# Unlike serial-tests, this option is accepted by Automake 1.11
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries