summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMario Sanchez Prada <mario@endlessm.com>2016-04-20 19:03:28 +0100
committerMario Sanchez Prada <mario@endlessm.com>2016-04-21 21:56:53 +0100
commit67582310b542a64583c590c43532e53a5b710d6e (patch)
tree5b9d4f87ca1ab7418afeb06ab6ee41e1fe6e7ba9 /configure.ac
parent065e06c6110b191d5a13aa3d8598fc9feac03a46 (diff)
Remove parallel version of WebHelper compatible with WebKit2-3.0
We are no longer shipping the Webkit2-3.0 API on Endless and Virtual School has already been migrated to the newer WebKit2-4.0 API after having fixed all the regressions there and so it makes no sense to keep this any longer. Besides, after the WebKitGTK+ upgrade from 2.4.9 to 2.4.11 debian does no longer ship the WebKit2GTK+-3.0 packages (and there's no point on us bringing them back) so, actually, we can not keep this anyway, so let's remove it. This commit basically reverts 8c837e660853abd03c97a98815f73146eb57c010, but considering all the changes integrated ever since (not a "clean" revert). https://phabricator.endlessm.com/T11388
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 8aa55f1..3e17d00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,6 @@ GIO_REQUIREMENT="gio-2.0"
GTK_REQUIREMENT="gtk+-3.0 >= 3.16"
JSON_GLIB_REQUIREMENT="json-glib-1.0 >= 0.12"
WEBKIT2_REQUIREMENT="webkit2gtk-4.0"
-WEBKIT2_OLD_REQUIREMENT="webkit2gtk-3.0"
# These go into the pkg-config file as Requires: and Requires.private:
# (Generally, use Requires.private: instead of Requires:)
EOS_REQUIRED_MODULES=
@@ -223,18 +222,10 @@ PKG_CHECK_MODULES([WEBHELPER2_EXTENSION], [
PKG_CHECK_MODULES([WEBHELPER2_PRIVATE], [
$GLIB_REQUIREMENT
$WEBKIT2_REQUIREMENT])
-PKG_CHECK_MODULES([WEBHELPER2_OLD_EXTENSION], [
- $GLIB_REQUIREMENT
- $GOBJECT_REQUIREMENT
- $WEBKIT2_OLD_REQUIREMENT])
-PKG_CHECK_MODULES([WEBHELPER2_OLD_PRIVATE], [
- $GLIB_REQUIREMENT
- $WEBKIT2_OLD_REQUIREMENT])
# Check installed GIRs for webhelper JS module
EOS_CHECK_GJS_GIR([GLib], [2.0])
EOS_CHECK_GJS_GIR([WebKit], [3.0])
-EOS_CHECK_GJS_GIR([WebKit2], [3.0])
EOS_CHECK_GJS_GIR([WebKit2], [4.0])
# Code coverage reports support