summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-08-31 12:54:08 -0700
committerPhilip Chimento <philip@endlessm.com>2015-08-31 17:06:17 -0700
commitac0d18a18ccd0873b62b332c14cd8547e72b1a5b (patch)
tree48e0d04aff63e6be5d6c608a047f80e274af0fda /docs
parentaf2bda2d010164308686f2c38b80c3dd21f10606 (diff)
Generate version macros from configure
This adds EOS_SDK_MAJOR_VERSION, EOS_SDK_MINOR_VERSION and EOS_SDK_MICRO_VERSION as macros in eosversion.h whose values are generated from configure with AC_SUBST, rather than in config.h using AC_DEFINE. They are also public API, so they get documenation and Since: annotations. [endlessm/eos-sdk#3071]
Diffstat (limited to 'docs')
-rw-r--r--docs/reference/endless/Makefile.am3
-rw-r--r--docs/reference/endless/endless-docs.xml5
-rw-r--r--docs/reference/endless/endless-sections.txt22
3 files changed, 10 insertions, 20 deletions
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index a4091ba..0570c33 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -49,7 +49,8 @@ EXTRA_HFILES=
# Header files or dirs to ignore when scanning. Use base file/dir names
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h private_code
-IGNORE_HFILES= eosinit-private.h \
+IGNORE_HFILES= eosapiversion-private.h \
+ eosinit-private.h \
eostopbar-private.h \
eosmainarea-private.h \
eosactionmenu-private.h \
diff --git a/docs/reference/endless/endless-docs.xml b/docs/reference/endless/endless-docs.xml
index d716d21..908da1a 100644
--- a/docs/reference/endless/endless-docs.xml
+++ b/docs/reference/endless/endless-docs.xml
@@ -46,6 +46,11 @@
<xi:include href="xml/api-index-0.4.xml"><xi:fallback /></xi:include>
</index>
+ <index id="api-index-0.6">
+ <title>Index of new API in 0.6</title>
+ <xi:include href="xml/api-index-0.6.xml"><xi:fallback /></xi:include>
+ </index>
+
<index id="deprecated-api-index" role="deprecated">
<title>Index of deprecated API</title>
<xi:include href="xml/api-index-deprecated.xml"><xi:fallback /></xi:include>
diff --git a/docs/reference/endless/endless-sections.txt b/docs/reference/endless/endless-sections.txt
index 549169c..d98978d 100644
--- a/docs/reference/endless/endless-sections.txt
+++ b/docs/reference/endless/endless-sections.txt
@@ -1,27 +1,11 @@
<SECTION>
<FILE>hello</FILE>
+EOS_SDK_MAJOR_VERSION
+EOS_SDK_MINOR_VERSION
+EOS_SDK_MICRO_VERSION
eos_hello_sample_function
eos_get_system_personality
<SUBSECTION Private>
-EOS_SDK_AVAILABLE_IN_0_0
-EOS_SDK_AVAILABLE_IN_0_2
-EOS_SDK_AVAILABLE_IN_0_4
-EOS_SDK_DEPRECATED
-EOS_SDK_DEPRECATED_FOR
-EOS_SDK_DEPRECATED_IN_0_0
-EOS_SDK_DEPRECATED_IN_0_0_FOR
-EOS_SDK_DEPRECATED_IN_0_2
-EOS_SDK_DEPRECATED_IN_0_2_FOR
-EOS_SDK_DEPRECATED_IN_0_4
-EOS_SDK_DEPRECATED_IN_0_4_FOR
-EOS_SDK_UNAVAILABLE
-EOS_SDK_VERSION_0_0
-EOS_SDK_VERSION_0_2
-EOS_SDK_VERSION_0_4
-EOS_SDK_VERSION_CUR_STABLE
-EOS_SDK_VERSION_MAX_ALLOWED
-EOS_SDK_VERSION_MIN_REQUIRED
-EOS_SDK_VERSION_PREV_STABLE
EOS_DEFINE_ENUM_TYPE
EOS_ENUM_VALUE
</SECTION>