summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-04-17 12:42:37 -0700
committerPhilip Chimento <philip@endlessm.com>2015-04-17 12:44:43 -0700
commit3c46d4730428b7f503d3d9df9c1d465ab22848fa (patch)
tree8534b7f3c064a8541bea08cb24919aa3cb736e3a /test/Makefile.am.inc
parent9910f0c3752b5e5150299cbedf0277bbee08a82c (diff)
Integrate Jasmine with Automake
This runs the tests during "make check" using jasmine-gjs, and outputs results in the TAP format that Automake understands. [endlessm/eos-sdk#3054]
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 1146eb7..7244a85 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -27,10 +27,15 @@ TESTS = \
test/endless/run-tests \
$(javascript_tests) \
$(NULL)
-TEST_EXTENSIONS =
+JS_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tap-driver.sh
+JS_LOG_DRIVER_FLAGS = --comments
+TEST_EXTENSIONS = .js
+JS_LOG_COMPILER = jasmine
AM_JS_LOG_FLAGS = \
--include-path=$(top_srcdir)/webhelper \
--include-path=$(top_srcdir) \
+ --tap \
+ --no-config \
$(NULL)
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose