summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimo@endlessm.com>2015-05-22 17:39:31 -0700
committerCosimo Cecchi <cosimo@endlessm.com>2015-05-22 18:10:06 -0700
commit81ddb87c4c466d779253c6a469f346a724b3b017 (patch)
tree0e94f94658595efcd058aeb3ccfe9a9849505997 /test/Makefile.am.inc
parentfe1109c96ca6185a26e293996c1bdf3871e3b09a (diff)
Run tests with run-with-dbus
Our JS tests require a session bus, but on Jenkins builder we won't have it. Run them with a test session bus. The run-with-dbus script is borrowed from GJS and simplified a bit. [endlessm/eos-sdk#291]
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 411d006..d8ed95c 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -58,7 +58,7 @@ TESTS = \
test/endless/run-tests \
$(javascript_tests) \
$(NULL)
-JS_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tap-driver.sh
+JS_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(top_srcdir)/test/run-with-dbus --session $(SHELL) $(top_srcdir)/tap-driver.sh
JS_LOG_DRIVER_FLAGS = --comments
TEST_EXTENSIONS = .js
JS_LOG_COMPILER = jasmine
@@ -71,6 +71,10 @@ AM_JS_LOG_FLAGS = \
$(NULL)
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose
+EXTRA_DIST += \
+ test/run-with-dbus \
+ test/test-bus.conf \
+ $(NULL)
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
@@ -81,4 +85,6 @@ TESTS_ENVIRONMENT = \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \
export WEBHELPER_UNINSTALLED_EXTENSION_DIR="$(top_builddir)/.libs"; \
+ export TOP_SRCDIR="$(abs_top_srcdir)"; \
+ export BUILDDIR=".";
$(NULL)