summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-10-23 21:58:49 -0700
committerPhilip Chimento <philip@endlessm.com>2013-10-23 22:00:01 -0700
commit758af67e4d3c48c530f11995351d5640231ed914 (patch)
tree6d231bddeba2928d9e6c16daa8f60871554ab991 /test/Makefile.am
parent6dfd4f24b97b1d3fa730b5f5c2c87f8e2d8c4fa4 (diff)
wiki: Add tests for refactored models
For good code hygiene, add tests for the models. After the refactoring, they are less linked together, so easier to test. [endlessm/eos-sdk#367]
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 60a4057..53ff6ff 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -35,6 +35,9 @@ javascript_tests = \
test/tools/eos-run-test/sanitycheck.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
+ test/wikipedia/models/testCategoryModel.js \
+ test/wikipedia/models/testArticleModel.js \
+ test/wikipedia/models/testDomainWikiModel.js \
$(NULL)
EXTRA_DIST += $(javascript_tests)
@@ -46,6 +49,7 @@ TESTS = \
TEST_EXTENSIONS = .js
JS_LOG_COMPILER = tools/eos-run-test
AM_JS_LOG_FLAGS = \
+ --include-path=$(top_srcdir)/wikipedia \
--include-path=$(top_srcdir)/webhelper \
$(NULL)
LOG_COMPILER = gtester