summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-11-27 20:09:10 -0800
committerPhilip Chimento <philip@endlessm.com>2013-11-27 20:09:10 -0800
commit789d44d5bcfa224803864f087ef979d48d80afdd (patch)
treef07382dfc584d680183528ebe8a9a493dad2e038 /test/Makefile.am
parentdde829bd1c4173ad469bae0bd90f2bcad4e88f75 (diff)
Set XDG_CONFIG_HOME to a temporary directory
This works around the race condition in GIO (https://bugzilla.gnome.org/show_bug.cgi?id=719455) while having the added benefit of not cluttering one's own config directory with a bunch of files every time the tests are run. [endlessm/eos-sdk#357]
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index dc8b662..81cae8c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -57,7 +57,10 @@ AM_LOG_FLAGS = -k --verbose
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
+# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config
+# directory with junk from the tests
TESTS_ENVIRONMENT = \
export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
+ export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \
$(NULL)