summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorMartin Abente Lahaye <martin@endlessm.com>2016-02-03 17:45:42 -0300
committerMartin Abente Lahaye <martin@endlessm.com>2016-02-08 13:48:29 -0300
commit7879a4eabadd00eeaebb0bfdcc0ee4be21ebb865 (patch)
treee25ec3f32d030fd856ab492d43416f8f9c6e3275 /test
parent6bd6edeebc66d528e7931d9f9b8b07d1648e33a3 (diff)
Add TopbarHomeButton
As agreed with the design team, all apps should include a generic home button at the top left corner of the app window. Therefore, we add a new generic button in the sdk to be used in all the different apps for consistency. [endlessm/eos-sdk#4030]
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc1
-rw-r--r--test/endless/testTopbarHomeButton.js14
2 files changed, 15 insertions, 0 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 2fca7ea..0fad7a2 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -53,6 +53,7 @@ javascript_tests = \
test/webhelper/testWebActions2Old.js \
test/webhelper/testUpdateFontSize.js \
test/endless/testCustomContainer.js \
+ test/endless/testTopbarHomeButton.js \
test/endless/testTopbarNavButton.js \
test/endless/testSearchBox.js \
$(NULL)
diff --git a/test/endless/testTopbarHomeButton.js b/test/endless/testTopbarHomeButton.js
new file mode 100644
index 0000000..1eeee73
--- /dev/null
+++ b/test/endless/testTopbarHomeButton.js
@@ -0,0 +1,14 @@
+const Endless = imports.gi.Endless;
+const Gtk = imports.gi.Gtk;
+
+Gtk.init(null);
+
+describe('TopbarHomeButton', function () {
+ let button;
+
+ beforeEach(function () {
+ button = new Endless.TopbarHomeButton();
+ });
+
+ it('can be constructed', function () {});
+});