summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorJuan Pablo Ugarte <ugarte@endlessm.com>2016-06-27 14:10:41 -0300
committerJuan Pablo Ugarte <ugarte@endlessm.com>2016-06-28 16:34:09 -0300
commitef52b9f5f2b563be144f104a9dcc5b32adec1966 (patch)
tree1ff1f960785fb7425e18288711b203c579b0c6cf /test
parentea6659d3c682088a6831dab567d14bbe65d05216 (diff)
Make sure target directory exists before compiling credits.gresource
https://phabricator.endlessm.com/T12150
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 727a5df..ba487c0 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -33,7 +33,8 @@ credits_resource_files = \
test/smoke-tests/images/attribution.json \
$(NULL)
test/smoke-tests/images/credits.gresource: test/smoke-tests/images/credits.gresource.xml $(credits_resource_files)
- $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
+ $(AM_V_GEN)$(MKDIR_P) $(@D) && \
+ $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
dist_noinst_DATA += test/smoke-tests/images/credits.gresource
CLEANFILES += test/smoke-tests/images/credits.gresource
EXTRA_DIST += \