summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/reference/endless/Makefile.am1
-rw-r--r--endless/eosactionmenu-private.h9
-rw-r--r--endless/eosactionmenu.c16
-rw-r--r--overrides/Endless.js10
4 files changed, 15 insertions, 21 deletions
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index b1dc6c6..00a813d 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -53,6 +53,7 @@ IGNORE_HFILES= eosinit-private.h \
eostopbar-private.h \
eosmainarea-private.h \
eosactionbutton-private.h \
+ eosactionmenu-private.h \
eospagemanager-private.h
# Images to copy into HTML directory.
diff --git a/endless/eosactionmenu-private.h b/endless/eosactionmenu-private.h
index 14c33d4..8b3755e 100644
--- a/endless/eosactionmenu-private.h
+++ b/endless/eosactionmenu-private.h
@@ -47,29 +47,22 @@ struct _EosActionMenuClass
GtkGridClass parent_class;
};
-EOS_SDK_ALL_API_VERSIONS
GType eos_action_menu_get_type (void) G_GNUC_CONST;
-EOS_SDK_ALL_API_VERSIONS
GtkWidget *eos_action_menu_new ();
-EOS_SDK_ALL_API_VERSIONS
void eos_action_menu_add_action (EosActionMenu *menu,
GtkAction *action);
-EOS_SDK_ALL_API_VERSIONS
GtkAction *eos_action_menu_get_action (EosActionMenu *menu,
const gchar *name);
-EOS_SDK_ALL_API_VERSIONS
-GList *eos_action_list_actions (EosActionMenu *menu);
+GList *eos_action_menu_list_actions (EosActionMenu *menu);
-EOS_SDK_ALL_API_VERSIONS
void eos_action_menu_remove_action (EosActionMenu *menu,
GtkAction *action);
-EOS_SDK_ALL_API_VERSIONS
void eos_action_menu_remove_action_by_name (EosActionMenu *menu,
const gchar *name);
diff --git a/endless/eosactionmenu.c b/endless/eosactionmenu.c
index 6e8fc0a..98ae77d 100644
--- a/endless/eosactionmenu.c
+++ b/endless/eosactionmenu.c
@@ -10,7 +10,7 @@
#define _EOS_STYLE_CLASS_ACTION_MENU "action-menu"
-/**
+/*
* SECTION:action-menu
* @short_description: Adding actions to the page
* @title: Action Menu
@@ -94,7 +94,7 @@ eos_action_menu_finalize (GObject *object)
/* ******* ACTION GROUP MGMT ******* */
-/**
+/*
* eos_action_menu_add_action:
* @menu: a #EosActionMenu
* @action: a #GtkAction: name, label, icon-name, is-important.
@@ -131,7 +131,7 @@ eos_action_menu_add_action (EosActionMenu *menu,
}
}
-/**
+/*
* eos_action_menu_get_action:
* @menu: an #EosActionMenu
* @name: the name of the action to retrieve
@@ -151,14 +151,14 @@ eos_action_menu_get_action (EosActionMenu *menu,
return gtk_action_group_get_action (priv->action_group, name);
}
-/**
- * eos_action_list_actions:
+/*
+ * eos_action_menu_list_actions:
* @menu: an #EosActionMenu
*
* Returns: (element-type GList) (transfer container): an allocated list of the action objects in the action group
*/
GList *
-eos_action_list_actions (EosActionMenu *menu)
+eos_action_menu_list_actions (EosActionMenu *menu)
{
EosActionMenuPrivate *priv;
g_return_val_if_fail (EOS_IS_ACTION_MENU (menu), NULL);
@@ -167,7 +167,7 @@ eos_action_list_actions (EosActionMenu *menu)
return gtk_action_group_list_actions (priv->action_group);
}
-/**
+/*
* eos_action_menu_remove_action:
* @menu: an #EosActionMenu
* @action: the action to remove
@@ -185,7 +185,7 @@ eos_action_menu_remove_action (EosActionMenu *menu,
gtk_action_group_remove_action(priv->action_group, action);
}
-/**
+/*
* eos_action_menu_remove_action_by_name:
* @menu: an #EosActionMenu
* @name: the name of the action to remove
diff --git a/overrides/Endless.js b/overrides/Endless.js
index 8fadd94..59e55ac 100644
--- a/overrides/Endless.js
+++ b/overrides/Endless.js
@@ -20,11 +20,11 @@ function _init() {
// GtkAction from the developer, as that will be deprecated in the future.
Endless.ActionMenu.prototype._add_action_real = Endless.ActionMenu.prototype.add_action;
Endless.ActionMenu.prototype.add_action = function(dict, callback) {
- let action = new Gtk.Action(dict);
- this._add_action_real(action);
+ let action = new Gtk.Action(dict);
+ this._add_action_real(action);
- if (typeof callback === "function") {
- action.connect('activate', callback);
- }
+ if (typeof callback === "function") {
+ action.connect('activate', callback);
+ }
}
}