summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index feee832..b2dce68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -146,6 +146,10 @@ gjsoverridedir = ${datadir}/gjs-1.0/overrides
dist_gjsoverride_DATA = \
overrides/Endless.js
+# # # SDK TOOLS # # #
+
+include $(top_srcdir)/tools/Makefile.am.inc
+
# # # INSTALLED M4 MACROS # # #
m4dir = ${datadir}/aclocal
@@ -158,6 +162,11 @@ m4_DATA = \
include $(top_srcdir)/test/Makefile.am
# Run tests when running 'make check'
-TESTS = test/run-tests
+TESTS = \
+ test/run-tests \
+ test/tools/eos-run-test/sanitycheck.js \
+ $(NULL)
+TEST_EXTENSIONS = .js
+JS_LOG_COMPILER = tools/eos-run-test
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose