summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 52f610d..707f883 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,8 @@ dist_noinst_DATA =
# Compiler flags
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
-AM_CFLAGS = @STRICT_CFLAGS@
+AM_CPPFLAGS = -I$(builddir)/endless # needed for eosversion.h include to work in out of tree builds
+AM_CFLAGS = @STRICT_CFLAGS@
# Make sure to run Gtk-doc tests and build the documentation when doing
# 'make distcheck'
@@ -146,6 +147,7 @@ Endless_@EOS_SDK_API_VERSION@_gir_INCLUDES = \
Endless_@EOS_SDK_API_VERSION@_gir_SCANNERFLAGS = \
--identifier-prefix=Eos \
--symbol-prefix=eos \
+ -I$(builddir)/endless \
-DCOMPILING_EOS_SDK
# Endless_@EOS_SDK_API_VERSION@_gir_CFLAGS = $(INCLUDES)
Endless_@EOS_SDK_API_VERSION@_gir_LIBS = libendless-@EOS_SDK_API_VERSION@.la