summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..85c0fe7
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,19 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+noinst_PROGRAMS = \
+ test/run-tests \
+ test/smoke-tests/hello
+
+TEST_FLAGS = @EOS_SDK_CFLAGS@ -I$(top_srcdir)
+TEST_LIBS = @EOS_SDK_LIBS@ $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la
+
+test_run_tests_SOURCES = \
+ test/run-tests.c \
+ test/test-init.c \
+ test/test-hello.c
+test_run_tests_CPPFLAGS = $(TEST_FLAGS)
+test_run_tests_LDADD = $(TEST_LIBS)
+
+test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
+test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
+test_smoke_tests_hello_LDADD = $(TEST_LIBS)