summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-11-05 10:50:56 -0400
committerJoey Hess <joey@kitenet.net>2014-11-05 10:50:56 -0400
commit6335925c321c39aad3556d7afb5651902659c559 (patch)
treed3866270aefa3958f5de228a4e71cca81ef28500
parentc5c69ebbd5bda0736fccc37421fe1b8f874f7407 (diff)
Add architecture info to dpkg list-installed. Closes: #768145
-rw-r--r--debian/changelog1
-rwxr-xr-xlist-installed.d/50list-installed2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 252dead..e08a204 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ etckeeper (1.16) UNRELEASED; urgency=medium
* Added support for Fedora's DNF highlevel package manager.
Thanks, Peter Listiak and Petr Spacek.
+ * Add architecture info to dpkg list-installed. Closes: #768145
-- Joey Hess <joeyh@debian.org> Tue, 28 Oct 2014 16:44:00 -0400
diff --git a/list-installed.d/50list-installed b/list-installed.d/50list-installed
index f392027..ac34202 100755
--- a/list-installed.d/50list-installed
+++ b/list-installed.d/50list-installed
@@ -3,7 +3,7 @@
# (or removed but still with config-files) packages, in the
# format "package version\n" (or something similar).
if [ "$LOWLEVEL_PACKAGE_MANAGER" = dpkg ]; then
- dpkg-query -W -f '${Status}\t${Package} ${Version}\n' | \
+ dpkg-query -W -f '${Status}\t${Package} ${Version} ${Architecture}\n' | \
egrep '(ok installed|ok config-files)' | cut -f2,3
elif [ "$LOWLEVEL_PACKAGE_MANAGER" = rpm ]; then
rpm -qa --qf "%|epoch?{%{epoch}}:{0}|:%{name}-%{version}-%{release}.%{arch}\n" | sort