summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac2
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rw-r--r--frontend/newparser/ParserDriver.cpp7
-rw-r--r--interpreter/icparser.y3
6 files changed, 22 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index a100719..fa3b348 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2013/07/03 Stefan Potyra <sistpoty@ubuntu.com>:
+ * generic: Fix build failures with gcc-4.8, adapt to changes
+ for new bison version (cf. DBTS: #710626).
+
2012/06/05 Stefan Potyra <sistpoty@ubuntu.com>:
* interpreter: Consistently use memory allocator / deallocator
callbacks.
diff --git a/configure.ac b/configure.ac
index 8cc5dd8..b1a86e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# $Id: configure.ac 5078 2010-12-17 14:25:10Z potyra $
-AC_INIT(fauhdlc, 20120707)
+AC_INIT(fauhdlc, 20130704)
# don't spam /
AC_CONFIG_AUX_DIR(scripts)
AM_INIT_AUTOMAKE
diff --git a/debian/changelog b/debian/changelog
index ba7d845..0a29e93 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+fauhdlc (20130704-1) unstable; urgency=low
+
+ * New upstream bugfix release:
+ Fix build failures with gcc-4.8 and new bison version
+ (Closes: #710626).
+ * debian/control: Update standards-version to 3.9.4 (no further changes
+ necessary).
+
+ -- Stefan Potyra <sistpoty@ubuntu.com> Wed, 03 Jul 2013 21:07:17 +0200
+
fauhdlc (20120707-1) unstable; urgency=low
* New upstream bugfix release: Use allocator/deallocator callbacks
diff --git a/debian/control b/debian/control
index 4f7d801..b14b083 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Build-Depends: debhelper (>= 5.0.0),
bison (>= 1:2.1),
flex,
python
-Standards-Version: 3.9.3
+Standards-Version: 3.9.4
Homepage: http://www.faumachine.org
Package: fauhdlc
diff --git a/frontend/newparser/ParserDriver.cpp b/frontend/newparser/ParserDriver.cpp
index a03e259..34387cd 100644
--- a/frontend/newparser/ParserDriver.cpp
+++ b/frontend/newparser/ParserDriver.cpp
@@ -1,4 +1,4 @@
-/* $Id: ParserDriver.cpp 5081 2010-12-17 15:16:21Z potyra $
+/* $Id: ParserDriver.cpp 5117 2013-06-01 11:30:20Z potyra $
*
* ParserDriver: glue class to driver between scanner and parser.
*
@@ -105,7 +105,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
// set up scanner
this->scanner = new FAUhdlScanner(&inStream, &std::cout);
- FAUhdlParser parser = FAUhdlParser(*this);
+ FAUhdlParser *parser = new FAUhdlParser(*this);
this->currentFile = new std::string(filename);
this->currentLibrary = this->topNode->enterLibrary(libName);
@@ -118,7 +118,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
this->symbolTable.pushNewRegion();
// parse stuff
- parser.parse();
+ parser->parse();
// close stream again
inStream.close();
@@ -129,6 +129,7 @@ ParserDriver::parse(const std::string& filename, const char* libName)
this->symbolTable.popRegion();
// leave library region again
this->symbolTable.popRegion();
+ delete parser;
}
void
diff --git a/interpreter/icparser.y b/interpreter/icparser.y
index 39bfaeb..d7332d6 100644
--- a/interpreter/icparser.y
+++ b/interpreter/icparser.y
@@ -1,4 +1,4 @@
-/* $Id: icparser.y 4974 2010-10-18 17:10:52Z potyra $
+/* $Id: icparser.y 5118 2013-06-01 11:31:09Z potyra $
*
* Intermediate code interpreter.
*
@@ -18,6 +18,7 @@
%{
#include "basetypes.h"
#include <assert.h>
+#include <stdio.h>
#include "fauhdli_private.h"
#include "list.h"
%}