summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@ringlet.net>2024-02-11 12:45:41 +0200
committerPeter Pentchev <roam@ringlet.net>2024-02-11 12:45:41 +0200
commit2c3735e746681b2bdcbb0e1f7641995701806fd8 (patch)
tree99a9dca7a66f80c58a1ea4e794e479d1854241ea
parenta81604909180fd13e85fdf82760601c86cd0b1db (diff)
Fix the no-arch-any FTBFS
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules13
2 files changed, 16 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 40d1012..37af1a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+feature-check (2.1.0-2) UNRELEASED; urgency=medium
+
+ * Fix the no-arch-any FTBFS: split the rules file targets into
+ -arch and -indep ones.
+
+ -- Peter Pentchev <roam@debian.org> Sun, 11 Feb 2024 12:45:15 +0200
+
feature-check (2.1.0-1) unstable; urgency=medium
* Minor improvements to the internal Tox tests for the autopkgtest helper:
diff --git a/debian/rules b/debian/rules
index e691fd7..b750b49 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ export PYTEST_ADDOPTS= ${PY}/tests/unit
%:
dh "$@"
-execute_after_dh_auto_build:
+execute_after_dh_auto_build-arch:
mkdir -p rust/.cargo
install -m 644 -- '$D/cargo-config.toml' '${RS}/.cargo/config.toml'
{ \
@@ -25,9 +25,10 @@ execute_after_dh_auto_build:
cargo build --release; \
}
+execute_after_dh_auto_build-indep:
dh_auto_build --buildsystem pybuild
-override_dh_auto_install:
+override_dh_auto_install-arch:
dh_auto_install -- \
PREFIX=/usr \
MANDIR=/usr/share/man/man \
@@ -36,17 +37,21 @@ override_dh_auto_install:
install -m 755 -- '${RS_BIN}' '${DTMP}/usr/bin/feature-check'
+override_dh_auto_install-indep:
dh_auto_install --buildsystem pybuild
-execute_after_dh_auto_test:
+execute_after_dh_auto_test-arch:
${MAKE} test-single TEST_PROG='${RS_BIN}'
+execute_after_dh_auto_test-indep:
env PYTHONPATH='${PY}/src' debian/tests/tappy.py
# dh_auto_test --buildsystem pybuild
override_dh_installchangelogs:
dh_installchangelogs -X changes.md
+
+execute_after_dh_installchangelogs-arch:
install -m 644 -- docs/changes.md '$D/feature-check/usr/share/doc/feature-check/NEWS'
-execute_after_dh_auto_clean:
+execute_after_dh_auto_clean-indep:
dh_auto_clean --buildsystem pybuild