summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMatthias Urlichs <smurf@debian.org>2004-04-03 12:39:31 +0200
committerMatthias Urlichs <smurf@debian.org>2004-04-03 12:39:31 +0200
commit531035115610631a0f063bd59116431885e4a517 (patch)
tree22b11edf00118216adbf63248e3ed62fa15a6637 /debian/rules
festlex-cmu (1.4.0-6) unstable; urgency=low
* Updated Maintained address to @d.o (pre-Sarge). * Standards-Version: 3.6.1 (no changes) # imported from the archive
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0f2d06f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build:
+ $(MAKE) -C lib/dicts/cmu
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ dh_clean
+
+# Build architecture-dependent files here.
+binary-arch: build
+# We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs usr/share/festival/dicts/cmu
+ cp lib/dicts/cmu/cmudict-*.out debian/tmp/usr/share/festival/dicts/cmu
+ cp lib/dicts/cmu/cmulex.scm lib/dicts/cmu/cmu_lts_rules.scm \
+ debian/tmp/usr/share/festival/dicts/cmu
+ dh_installdocs
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary