summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Gevers <elbrus@debian.org>2015-11-04 12:43:57 +0100
committerPaul Gevers <elbrus@debian.org>2015-11-04 14:38:25 +0100
commit9d64ad4bbc33a11ba90fc4f5b565255a4a5ab100 (patch)
tree89e8909bf6aef9bef49450b16cd6d7f9c411ff17
parent7751b3a745b446454a9363030e2cfb11f37bbc66 (diff)
Migrate to shortstyle debhelper
-rw-r--r--debian/festlex-oald.install2
-rwxr-xr-xdebian/rules35
2 files changed, 6 insertions, 31 deletions
diff --git a/debian/festlex-oald.install b/debian/festlex-oald.install
new file mode 100644
index 0000000..20cb5dc
--- /dev/null
+++ b/debian/festlex-oald.install
@@ -0,0 +1,2 @@
+lib/dicts/oald/oald-*.out usr/share/festival/dicts/oald
+lib/dicts/oald/*.scm usr/share/festival/dicts/oald
diff --git a/debian/rules b/debian/rules
index f2f64b0..ed6c491 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,37 +1,10 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-build:
- $(MAKE) -C lib/dicts/oald
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- dh_clean
-
-# Build architecture-dependent files here.
-binary-arch: build
-# We have nothing to do by default.
+%:
+ dh ${@}
-# Build architecture-independent files here.
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_installdirs usr/share/festival/dicts/oald
- cp lib/dicts/oald/oald-*.out debian/tmp/usr/share/festival/dicts/oald
- cp lib/dicts/oald/*.scm debian/tmp/usr/share/festival/dicts/oald
- dh_installdocs
- dh_installchangelogs
- dh_compress
- dh_fixperms
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+build-indep:
+ $(MAKE) -C lib/dicts/oald