summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Reed <m.reed@mykolab.com>2015-12-12 15:17:53 -0500
committerWill Estes <westes575@gmail.com>2015-12-12 15:40:58 -0500
commite05e093047d8558b09abd97eb0b0cd4af7df1b0b (patch)
tree54a775727787548fd7a043a91239bf1fb7df5fe5
parent77e54b25ee67ff066d8619d790b43cb2da227ae6 (diff)
Removed SHORT_FILE_NAMES preprocessor symbol.
As a relic of MS-DOS, we don't need this. It's never defined; see 13b5b214f53d1c3354a7ab910bd160c126df1331. Removed additional MSDOS ifdef.
-rw-r--r--Makefile.am5
-rw-r--r--src/main.c10
2 files changed, 0 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 076ccad..fd8eb1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,11 +27,6 @@
# and 7-bit scanners when using uncompressed tables (-f or -F options).
# For flex to always generate 8-bit scanners, add "-DDEFAULT_CSIZE=256"
# to DEFS.
-#
-# For Vax/VMS, add "-DVMS" to DEFS.
-#
-# For MS-DOS, add "-DMS_DOS" to DEFS. See the directory MISC/MSDOS for
-# additional info.
ACLOCAL_AMFLAGS = -I m4
indent = @INDENT@
diff --git a/src/main.c b/src/main.c
index c276bc4..a817c80 100644
--- a/src/main.c
+++ b/src/main.c
@@ -117,19 +117,9 @@ struct yytbl_writer tableswr;
*/
char *program_name = "flex";
-#ifndef SHORT_FILE_NAMES
static const char outfile_template[] = "lex.%s.%s";
static const char backing_name[] = "lex.backup";
static const char tablesfile_template[] = "lex.%s.tables";
-#else
-static const char outfile_template[] = "lex%s.%s";
-static const char backing_name[] = "lex.bck";
-static const char tablesfile_template[] = "lex%s.tbl";
-#endif
-
-#ifdef MS_DOS
-extern unsigned _stklen = 16384;
-#endif
/* From scan.l */
extern FILE* yyout;