summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-25 16:50:07 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-25 17:55:36 -0800
commit45bace6d30eebcc9e3f0a5eae7ea5cad93357831 (patch)
tree37cad7eb233e01f5a6a0674028482ace7c86e587 /configure.ac
parent65e118250752da4f02b0e7fd3c8ca0dd48851385 (diff)
Changes to let flex crosscompiledebian/2.6.0-2
Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c519dc..4af4a1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,12 @@ AC_PROG_INSTALL
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
+if test "$cross_compiling" = yes; then
+FLEXexe='flex$(EXEEXT)'
+else
+FLEXexe='$(top_builddir)/flex$(EXEEXT)'
+fi
+AC_SUBST(FLEXexe)
# Check for a m4 that supports -P