summaryrefslogtreecommitdiff
path: root/src/flex.skl
diff options
context:
space:
mode:
authorNiels Thykier <niels@thykier.net>2018-08-06 12:40:25 -0700
committerNiels Thykier <niels@thykier.net>2018-08-06 12:40:25 -0700
commita180cb6af61aec3423a856afec59248ef132a88e (patch)
tree8f3145e074fb78f1f753ab8a91829599ae3f357f /src/flex.skl
parent2a70951b3ee5ae119749f79458df981134b248cd (diff)
flex (2.6.4-6.2) unstable; urgency=medium
* Non-maintainer upload. [ Ruben Undheim ] * debian/rules: - Fix build with "dpkg-buildpackage -A" by checking if directory exists first (Closes: #898725) [ Niels Thykier ] * debian/control: - Set Rules-Requires-Root (R³) to no as flex does not need/require (fake)root during package build. [dgit import package flex 2.6.4-6.2]
Diffstat (limited to 'src/flex.skl')
-rw-r--r--src/flex.skl6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/flex.skl b/src/flex.skl
index 786c977..ba194a2 100644
--- a/src/flex.skl
+++ b/src/flex.skl
@@ -15,7 +15,7 @@
%# The quoting is "[[" and "]]" so we don't interfere with
%# user code.
%#
-%# All generate macros for the m4 stage contain the text "m4" or "M4"
+%# All generated macros for the m4 stage contain the text "m4" or "M4"
%# in them. This is to distinguish them from CPP macros.
%# The exception to this rule is YY_G, which is an m4 macro,
%# but it needs to be remain short because it is used everywhere.
@@ -3292,9 +3292,7 @@ static int yytbl_data_load YYFARGS2(struct yytbl_dmap *, dmap, struct yytbl_read
/* Now eat padding. */
{
- int pad;
- pad = yypad64(rd->bread);
- while(--pad >= 0){
+ while (rd->bread % (8 * sizeof(flex_uint8_t)) > 0) {
flex_int8_t t8;
if(yytbl_read8(&t8,rd) != 0)
return -1;