summaryrefslogtreecommitdiff
path: root/src/regex.c
diff options
context:
space:
mode:
authorNiels Thykier <niels@thykier.net>2018-08-06 12:40:25 -0700
committerNiels Thykier <niels@thykier.net>2018-08-06 12:40:25 -0700
commita180cb6af61aec3423a856afec59248ef132a88e (patch)
tree8f3145e074fb78f1f753ab8a91829599ae3f357f /src/regex.c
parent2a70951b3ee5ae119749f79458df981134b248cd (diff)
flex (2.6.4-6.2) unstable; urgency=medium
* Non-maintainer upload. [ Ruben Undheim ] * debian/rules: - Fix build with "dpkg-buildpackage -A" by checking if directory exists first (Closes: #898725) [ Niels Thykier ] * debian/control: - Set Rules-Requires-Root (R³) to no as flex does not need/require (fake)root during package build. [dgit import package flex 2.6.4-6.2]
Diffstat (limited to 'src/regex.c')
-rw-r--r--src/regex.c4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/regex.c b/src/regex.c
index 38e658b..f4c4163 100644
--- a/src/regex.c
+++ b/src/regex.c
@@ -25,10 +25,8 @@
static const char* REGEXP_LINEDIR = "^#line ([[:digit:]]+) \"(.*)\"";
-static const char* REGEXP_BLANK_LINE = "^[[:space:]]*$";
regex_t regex_linedir; /**< matches line directives */
-regex_t regex_blank_line; /**< matches blank lines */
/** Initialize the regular expressions.
@@ -37,8 +35,6 @@ regex_t regex_blank_line; /**< matches blank lines */
bool flex_init_regex(void)
{
flex_regcomp(&regex_linedir, REGEXP_LINEDIR, REG_EXTENDED);
- flex_regcomp(&regex_blank_line, REGEXP_BLANK_LINE, REG_EXTENDED);
-
return true;
}