summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-19 02:37:04 +0800
committerWill Estes <westes575@gmail.com>2016-11-24 18:45:07 -0500
commit713f5a0cb4ba5e4bfebae125edf4111fd8dae803 (patch)
tree3f648b9c502e61a3f02b8482abc592d18eda5124 /src
parent11c445cde95ec4ba146b180bf3a2501cc6e255da (diff)
build: Link $(LIBOBJS) from src/ dir, remove libcompat.la.
The libcompat.la library was small and less friendly to bootstrapping and cross compilation. Now, we will simply link individual object files as needed, which is simpler.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5b34d4..fdd3c92 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -59,7 +59,7 @@ COMMON_SOURCES = \
version.h \
yylex.c
-LDADD = ../lib/libcompat.la @LIBINTL@
+LDADD = $(LIBOBJS) @LIBINTL@
include_HEADERS = \
FlexLexer.h