summaryrefslogtreecommitdiff
path: root/tests/prefix_nr.l
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
commitf753f2b7b6d97014110dbe418861353a2f3f445d (patch)
tree7f248ce2f59fbb79cab24b4727955e37e9a5ab81 /tests/prefix_nr.l
parent306163051847aaaabe7ae0f4cfc7d23f15923f3a (diff)
parenta646b6cd438dc4bd957c6c6afd89b5e8e59468fe (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # INSTALL # Makefile.in # aclocal.m4 # build-aux/compile # build-aux/config.guess # build-aux/config.sub # build-aux/depcomp # build-aux/install-sh # build-aux/mdate-sh # build-aux/texinfo.tex # configure # doc/Makefile.in # doc/flex.1 # doc/flex.info # doc/flex.info-1 # doc/flex.info-2 # doc/flex.pdf # doc/stamp-vti # doc/version.texi # examples/Makefile.in # examples/fastwc/Makefile.in # examples/manual/Makefile.in # src/config.h.in # tests/Makefile.in # tests/test-bison-nr/Makefile.am # tests/test-bison-yylloc/Makefile.am # tests/test-bison-yylval/Makefile.am # tools/Makefile.in
Diffstat (limited to 'tests/prefix_nr.l')
-rw-r--r--tests/prefix_nr.l75
1 files changed, 75 insertions, 0 deletions
diff --git a/tests/prefix_nr.l b/tests/prefix_nr.l
new file mode 100644
index 0000000..c1665df
--- /dev/null
+++ b/tests/prefix_nr.l
@@ -0,0 +1,75 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+/* Builds "scanner.c". */
+/* The scanner itself is a no-op. A successful compilation is all we want. */
+#include <stdio.h>
+#include <stdlib.h>
+#include "config.h"
+
+%}
+
+%option 8bit prefix="FOO"
+%option nounput nomain noyywrap noinput
+%option warn
+
+
+%%
+
+.|\n|\r {
+
+ /* Compile, but do not execute the following code. */
+ if( 0) {
+ FOO_create_buffer((FILE*)0,0);
+ FOO_delete_buffer((YY_BUFFER_STATE)0);
+ FOO_flush_buffer((YY_BUFFER_STATE)0);
+ FOO_init_buffer((YY_BUFFER_STATE)0,(FILE*)0);
+ FOO_load_buffer_state();
+ FOO_scan_buffer((char*)0,(yy_size_t)0);
+ FOO_scan_bytes((yyconst char*)0, 0);
+ FOO_scan_string((yyconst char*)0);
+ FOO_switch_to_buffer((YY_BUFFER_STATE)0);
+ yyin = (FILE*)0;
+ yyout = (FILE*)0;
+ yyleng = 0;
+ yylex();
+ yyrestart((FILE*)0);
+ yytext = (char*)0;
+ }
+ }
+%%
+
+
+int main(void);
+
+int
+main ()
+{
+ yyin = stdin;
+ yyout = stdout;
+ FOOlex();
+ printf("TEST RETURNING OK.\n");
+ return 0;
+}
+