summaryrefslogtreecommitdiff
path: root/tests/test-reject/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-reject/Makefile.am')
-rw-r--r--tests/test-reject/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/tests/test-reject/Makefile.am b/tests/test-reject/Makefile.am
index 2a9c3e2..64de331 100644
--- a/tests/test-reject/Makefile.am
+++ b/tests/test-reject/Makefile.am
@@ -23,7 +23,7 @@
FLEX = $(top_builddir)/flex
EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c test-reject-* OUTPUT $(OBJS)
+CLEANFILES = scanner.c $(testname)$(EXEEXT)-* OUTPUT $(OBJS)
OBJS = test-reject-nr.o test-reject-r.o test-reject-ver.o \
test-reject-ser.o
@@ -65,5 +65,16 @@ test: $(tests)
./$(testname)-ver$(EXEEXT) $(testname)-ver.tables < $(srcdir)/test.input
./$(testname)-ser$(EXEEXT) $(testname)-ser.tables < $(srcdir)/test.input
-.c.o:
+test-reject-nr.o: test-reject-nr.c
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
+
+test-reject-ver.o: test-reject-ver.c
+ $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) -DTEST_HAS_TABLES_EXTERNAL $(CFLAGS) $<
+
+test-reject-ser.o: test-reject-ser.c
+ $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) -DTEST_HAS_TABLES_EXTERNAL $(CFLAGS) $<
+
+test-reject-r.o: test-reject-r.c
+ $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) -DTEST_IS_REENTRANT $(CFLAGS) $<
+
+