summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2008-01-26 20:07:06 +0000
committerAaron M. Ucko <ucko@debian.org>2008-01-26 20:07:06 +0000
commitd22d93635e12f094b2dc8fec32bf851e3d8a9213 (patch)
tree4e5ea24cbf2328ab51ac6b079a9c1f3d1d1f74c7 /Makefile
parentec35289ce9ae8e103555544b35ea87960d7d7851 (diff)
[svn-upgrade] Integrating new upstream version, fltk1.1 (1.1.8~r6021)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2896cdc..6398203 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
#
-# "$Id: Makefile 5788 2007-05-01 14:28:23Z matt $"
+# "$Id: Makefile 5985 2007-11-20 21:15:08Z mike $"
#
# Top-level makefile for the Fast Light Tool Kit (FLTK).
#
-# Copyright 1998-2006 by Bill Spitzak and others.
+# Copyright 1998-2007 by Bill Spitzak and others.
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Library General Public
@@ -29,7 +29,7 @@ include makeinclude
DIRS = $(IMAGEDIRS) src fluid test documentation
-all: makeinclude
+all: makeinclude fltk-config
for dir in $(DIRS); do\
echo "=== making $$dir ===";\
(cd $$dir; $(MAKE) $(MFLAGS)) || exit 1;\
@@ -90,6 +90,16 @@ distclean: clean
$(RM) test/`basename $$file .fl`.h; \
done
+fltk-config: configure configh.in fltk-config.in
+ if test -f config.status; then \
+ ./config.status --recheck; \
+ ./config.status; \
+ else \
+ ./configure; \
+ fi
+ touch config.h
+ chmod +x fltk-config
+
makeinclude: configure configh.in makeinclude.in
if test -f config.status; then \
./config.status --recheck; \
@@ -113,5 +123,5 @@ etags:
etags FL/*.H FL/*.h src/*.cxx src/*.c src/*.h fluid/*.h fluid/*.cxx test/*.h test/*.cxx
#
-# End of "$Id: Makefile 5788 2007-05-01 14:28:23Z matt $".
+# End of "$Id: Makefile 5985 2007-11-20 21:15:08Z mike $".
#