summaryrefslogtreecommitdiff
path: root/zlib
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2006-01-20 02:00:49 +0000
committerAaron M. Ucko <ucko@debian.org>2006-01-20 02:00:49 +0000
commita7324bb0c2a26bb02be3362dff2126dc6c6af3a4 (patch)
tree64e6a26efbbc09e90a07afcf91a4b968d906955e /zlib
parent561e57f79c1c365a2ff6c31fc32f36ba70d21cae (diff)
Load /tmp/.../fltk1.1-1.1.7 into
branches/upstream/current.
Diffstat (limited to 'zlib')
-rw-r--r--zlib/CMakeLists.txt1
-rw-r--r--zlib/ChangeLog2
-rw-r--r--zlib/Makefile6
-rw-r--r--zlib/adler32.c2
-rw-r--r--zlib/compress.c2
-rw-r--r--zlib/crc32.c2
-rw-r--r--zlib/deflate.c2
-rw-r--r--zlib/deflate.h2
-rw-r--r--zlib/gzio.c2
-rw-r--r--zlib/inftrees.c2
-rw-r--r--zlib/makefile.wat120
-rw-r--r--zlib/trees.c2
-rw-r--r--zlib/uncompr.c2
-rw-r--r--zlib/zconf.h2
-rw-r--r--zlib/zutil.c2
-rw-r--r--zlib/zutil.h2
16 files changed, 77 insertions, 76 deletions
diff --git a/zlib/CMakeLists.txt b/zlib/CMakeLists.txt
index e96ce84..006a763 100644
--- a/zlib/CMakeLists.txt
+++ b/zlib/CMakeLists.txt
@@ -11,4 +11,5 @@ inflate.c inftrees.c trees.c uncompr.c zutil.c
)
ADD_LIBRARY(fltk_zlib ${ZLIB_SRCS})
+INSTALL_TARGETS(/lib fltk_zlib)
diff --git a/zlib/ChangeLog b/zlib/ChangeLog
index d344769..553774c 100644
--- a/zlib/ChangeLog
+++ b/zlib/ChangeLog
@@ -466,7 +466,7 @@ Changes in 1.0.6 (19 Jan 1998)
- use _fdopen instead of fdopen for MSC >= 6.0 (Thomas Fanslau)
- added makelcc.bat for lcc-win32 (Tom St Denis)
- in Makefile.dj2, use copy and del instead of install and rm (Frank Donahoe)
-- Avoid expanded $Id: ChangeLog,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $. Use "rcs -kb" or "cvs admin -kb" to avoid Id expansion.
+- Avoid expanded $Id: ChangeLog 3809 2004-09-08 16:04:43Z easysw $. Use "rcs -kb" or "cvs admin -kb" to avoid Id expansion.
- check for unistd.h in configure (for off_t)
- remove useless check parameter in inflate_blocks_free
- avoid useless assignment of s->check to itself in inflate_blocks_new
diff --git a/zlib/Makefile b/zlib/Makefile
index b8e3758..398504b 100644
--- a/zlib/Makefile
+++ b/zlib/Makefile
@@ -1,9 +1,9 @@
#
-# "$Id: Makefile,v 1.1.2.6 2004/09/08 16:04:42 easysw Exp $"
+# "$Id: Makefile 4052 2005-02-24 21:55:12Z mike $"
#
# GNU ZIP library makefile for the Fast Light Toolkit (FLTK).
#
-# Copyright 1997-2004 by Easy Software Products.
+# Copyright 1997-2005 by Easy Software Products.
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Library General Public
@@ -103,5 +103,5 @@ $(OBJS): ../makeinclude
#
-# End of "$Id: Makefile,v 1.1.2.6 2004/09/08 16:04:42 easysw Exp $".
+# End of "$Id: Makefile 4052 2005-02-24 21:55:12Z mike $".
#
diff --git a/zlib/adler32.c b/zlib/adler32.c
index f225f54..9b0660b 100644
--- a/zlib/adler32.c
+++ b/zlib/adler32.c
@@ -3,7 +3,7 @@
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-/* @(#) $Id: adler32.c,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $ */
+/* @(#) $Id: adler32.c 4052 2005-02-24 21:55:12Z mike $ */
#define ZLIB_INTERNAL
#include "zlib.h"
diff --git a/zlib/compress.c b/zlib/compress.c
index bddae08..b6eed62 100644
--- a/zlib/compress.c
+++ b/zlib/compress.c
@@ -3,7 +3,7 @@
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-/* @(#) $Id: compress.c,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $ */
+/* @(#) $Id: compress.c 4052 2005-02-24 21:55:12Z mike $ */
#define ZLIB_INTERNAL
#include "zlib.h"
diff --git a/zlib/crc32.c b/zlib/crc32.c
index b3e0b97..ace11f1 100644
--- a/zlib/crc32.c
+++ b/zlib/crc32.c
@@ -9,7 +9,7 @@
* of two increase in speed on a Power PC G4 (PPC7455) using gcc -O3.
*/
-/* @(#) $Id: crc32.c,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $ */
+/* @(#) $Id: crc32.c 4052 2005-02-24 21:55:12Z mike $ */
#ifdef MAKECRCH
# include <stdio.h>
diff --git a/zlib/deflate.c b/zlib/deflate.c
index 0ce30a6..83de499 100644
--- a/zlib/deflate.c
+++ b/zlib/deflate.c
@@ -47,7 +47,7 @@
*
*/
-/* @(#) $Id: deflate.c,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $ */
+/* @(#) $Id: deflate.c 4052 2005-02-24 21:55:12Z mike $ */
#include "deflate.h"
diff --git a/zlib/deflate.h b/zlib/deflate.h
index b939d43..1c9e4a8 100644
--- a/zlib/deflate.h
+++ b/zlib/deflate.h
@@ -8,7 +8,7 @@
subject to change. Applications should only use zlib.h.
*/
-/* @(#) $Id: deflate.h,v 1.1.2.2 2004/09/08 16:04:42 easysw Exp $ */
+/* @(#) $Id: deflate.h 4052 2005-02-24 21:55:12Z mike $ */
#ifndef DEFLATE_H
#define DEFLATE_H
diff --git a/zlib/gzio.c b/zlib/gzio.c
index 615664e..21024d2 100644
--- a/zlib/gzio.c
+++ b/zlib/gzio.c
@@ -5,7 +5,7 @@
* Compile this file with -DNO_GZCOMPRESS to avoid the compression code.
*/
-/* @(#) $Id: gzio.c,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: gzio.c 4052 2005-02-24 21:55:12Z mike $ */
#include <stdio.h>
diff --git a/zlib/inftrees.c b/zlib/inftrees.c
index 3bb5639..0b791af 100644
--- a/zlib/inftrees.c
+++ b/zlib/inftrees.c
@@ -126,7 +126,7 @@ unsigned short FAR *work;
left -= count[len];
if (left < 0) return -1; /* over-subscribed */
}
- if (left > 0 && (type == CODES || (codes - count[0] != 1)))
+ if (left > 0 && (type == CODES || max != 1))
return -1; /* incomplete set */
/* generate offsets into symbol table for each length for sorting */
diff --git a/zlib/makefile.wat b/zlib/makefile.wat
index ecf951e..00a8755 100644
--- a/zlib/makefile.wat
+++ b/zlib/makefile.wat
@@ -1,60 +1,60 @@
-#
-# "$Id: makefile.wat,v 1.1.2.1 2004/11/20 03:19:59 easysw Exp $"
-#
-# GNU ZIP library makefile for the Fast Light Toolkit (FLTK).
-#
-# Copyright 1997-2004 by Easy Software Products.
-#
-# This library is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Library General Public
-# License as published by the Free Software Foundation; either
-# version 2 of the License, or (at your option) any later version.
-#
-# This library is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this library; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA.
-#
-# Please report all bugs and problems to "fltk-bugs@fltk.org".
-#
-
-LIBNAMEROOT=ftlk_z
-
-!include ../watcom.mif
-
-
-#
-# Object files...
-#
-
-LIBOBJS = adler32.obj compress.obj crc32.obj gzio.obj uncompr.obj deflate.obj &
- trees.obj zutil.obj inflate.obj inftrees.obj inffast.obj
-
-
-#
-# Make all targets...
-#
-
-all: $(LIBNAME)
-
-$(LIBNAME): $(LIBOBJS)
- $(LIB) $(LIBOPTS) $@ $<
-
-#
-# Clean all directories
-#
-clean : .SYMBOLIC
- @echo Cleaning up.
-CLEANEXTS = obj
- @for %a in ($(CLEANEXTS)) do -rm -f $(ODIR)\*.%a
- -rm -f *.err
- -rm -f $(LIBNAME)
-
-#
-# End of "$Id: makefile.wat,v 1.1.2.1 2004/11/20 03:19:59 easysw Exp $".
-#
+#
+# "$Id: makefile.wat 4359 2005-05-19 16:07:13Z mike $"
+#
+# GNU ZIP library makefile for the Fast Light Toolkit (FLTK).
+#
+# Copyright 1997-2004 by Easy Software Products.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+LIBNAMEROOT=ftlk_z
+
+!include ../watcom.mif
+
+
+#
+# Object files...
+#
+
+LIBOBJS = adler32.obj compress.obj crc32.obj gzio.obj uncompr.obj deflate.obj &
+ trees.obj zutil.obj inflate.obj inftrees.obj inffast.obj
+
+
+#
+# Make all targets...
+#
+
+all: $(LIBNAME)
+
+$(LIBNAME): $(LIBOBJS)
+ $(LIB) $(LIBOPTS) $@ $<
+
+#
+# Clean all directories
+#
+clean : .SYMBOLIC
+ @echo Cleaning up.
+CLEANEXTS = obj
+ @for %a in ($(CLEANEXTS)) do -rm -f $(ODIR)\*.%a
+ -rm -f *.err
+ -rm -f $(LIBNAME)
+
+#
+# End of "$Id: makefile.wat 4359 2005-05-19 16:07:13Z mike $".
+#
diff --git a/zlib/trees.c b/zlib/trees.c
index 00fa061..3672bbc 100644
--- a/zlib/trees.c
+++ b/zlib/trees.c
@@ -29,7 +29,7 @@
* Addison-Wesley, 1983. ISBN 0-201-06672-6.
*/
-/* @(#) $Id: trees.c,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: trees.c 4052 2005-02-24 21:55:12Z mike $ */
/* #define GEN_TREES_H */
diff --git a/zlib/uncompr.c b/zlib/uncompr.c
index ea73a95..f277802 100644
--- a/zlib/uncompr.c
+++ b/zlib/uncompr.c
@@ -3,7 +3,7 @@
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-/* @(#) $Id: uncompr.c,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: uncompr.c 4052 2005-02-24 21:55:12Z mike $ */
#define ZLIB_INTERNAL
#include "zlib.h"
diff --git a/zlib/zconf.h b/zlib/zconf.h
index dce0122..193a5ac 100644
--- a/zlib/zconf.h
+++ b/zlib/zconf.h
@@ -3,7 +3,7 @@
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-/* @(#) $Id: zconf.h,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: zconf.h 4052 2005-02-24 21:55:12Z mike $ */
#ifndef ZCONF_H
#define ZCONF_H
diff --git a/zlib/zutil.c b/zlib/zutil.c
index 104ff97..1b49b40 100644
--- a/zlib/zutil.c
+++ b/zlib/zutil.c
@@ -3,7 +3,7 @@
* For conditions of distribution and use, see copyright notice in zlib.h
*/
-/* @(#) $Id: zutil.c,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: zutil.c 4052 2005-02-24 21:55:12Z mike $ */
#include "zutil.h"
diff --git a/zlib/zutil.h b/zlib/zutil.h
index 16d24ee..370b96a 100644
--- a/zlib/zutil.h
+++ b/zlib/zutil.h
@@ -8,7 +8,7 @@
subject to change. Applications should only use zlib.h.
*/
-/* @(#) $Id: zutil.h,v 1.1.2.2 2004/09/08 16:04:43 easysw Exp $ */
+/* @(#) $Id: zutil.h 4052 2005-02-24 21:55:12Z mike $ */
#ifndef ZUTIL_H
#define ZUTIL_H