summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2017-08-08 14:06:55 -0400
committerAaron M. Ucko <ucko@debian.org>2017-08-08 14:10:17 -0400
commit78f6ff86aef367bdd960a530ad0d87f19cc8a6fc (patch)
tree908d4b4aac88415601f008c68638bf71a17ac236
parent2fb3b12f8288a1993d8eda60d44df061c80e3c1c (diff)
fltk1.3 1.3.4-6: Correct doubled multiarch paths (#871508).debian/1.3.4-6archive/debian/1.3.4-6
* debian/fix-fltk-targets-noconfig: Correct overzealous escaping that led to doubled multiarch paths for some settings. (Closes: #871508.)
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/fix-fltk-targets-noconfig2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a65c81b..6e71557 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+fltk1.3 (1.3.4-6) unstable; urgency=medium
+
+ * debian/fix-fltk-targets-noconfig: Correct overzealous escaping that led
+ to doubled multiarch paths for some settings. (Closes: #871508.)
+
+ -- Aaron M. Ucko <ucko@debian.org> Tue, 08 Aug 2017 14:06:54 -0400
+
fltk1.3 (1.3.4-5) unstable; urgency=medium
* debian/{compat,control}: Advance to Debhelper 10.
diff --git a/debian/fix-fltk-targets-noconfig b/debian/fix-fltk-targets-noconfig
index 1a4a404..71d6f04 100755
--- a/debian/fix-fltk-targets-noconfig
+++ b/debian/fix-fltk-targets-noconfig
@@ -3,7 +3,7 @@ use strict;
my $to_untag = '';
while (<>) {
- s,(\$\{_IMPORT_PREFIX}/lib)(?!/$ENV\{DEB_HOST_MULTIARCH}),$1/$ENV{DEB_HOST_MULTIARCH},g;
+ s,(\$\{_IMPORT_PREFIX}/lib)(?!/$ENV{DEB_HOST_MULTIARCH}),$1/$ENV{DEB_HOST_MULTIARCH},g;
s,\.so\.1\.3\.\d*,\.so,g;
s,([^a-z]fltk\w*(?<!_SHARED))(\W),${1}_STATIC$2,g;
s,(libfltk\w*)_SHARED,$1,g;