summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2022-09-07 21:50:29 -0400
committerAaron M. Ucko <ucko@debian.org>2022-09-07 21:50:29 -0400
commit8280fa177a2438d25932f0b0ec60680ab6013a61 (patch)
tree783fdfd7db87ac4c06e2e4417f01e3489fa0eab5
parent14a207918f082c7c897fb3ba60d068facd579705 (diff)
rules: Unhardcode path to stock FLTK-Targets(-none).cmake (#1017271)
Per https://gitlab.kitware.com/cmake/cmake/-/issues/23883, CMakeTmp/CMakeFiles/Export's subdirectory names are hexadecimal MD5 hash values as of CMake 3.24; automatic detection allows backports to keep working and accommodates possible future layout changes.
-rw-r--r--debian/changelog10
-rwxr-xr-xdebian/rules13
2 files changed, 14 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 980aae5..75ad917 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
fltk1.3 (1.3.8-5) UNRELEASED; urgency=medium
* NOT RELEASED YET.
-
- -- Aaron M. Ucko <ucko@debian.org> Wed, 07 Sep 2022 21:31:46 -0400
+ * debian/rules: Unhardcode path to stock FLTK-Targets(-none).cmake.
+ Per https://gitlab.kitware.com/cmake/cmake/-/issues/23883,
+ CMakeTmp/CMakeFiles/Export's subdirectory names are hexadecimal MD5
+ hash values as of CMake 3.24; automatic detection allows backports to
+ keep working and accommodates possible future layout changes.
+ (Closes: #1017271.)
+
+ -- Aaron M. Ucko <ucko@debian.org> Wed, 07 Sep 2022 21:50:29 -0400
fltk1.3 (1.3.8-4) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 1759338..e349c89 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,13 +44,12 @@ ifneq "" "$(filter libfltk1.3-dev, $(shell dh_listpackages))"
dh_auto_configure -S cmake -B CMakeTmp -- -DOPTION_CAIRO:BOOL=ON \
-DOPTION_BUILD_SHARED_LIBS:BOOL=ON -DOPTION_CREATE_LINKS:BOOL=ON \
-DFLTK_BUILD_TEST:BOOL=OFF
- debian/fix-fltk-targets \
- debian/FLTK-Targets-head.cmake \
- CMakeTmp/CMakeFiles/Export/share/fltk/FLTK-Targets.cmake \
- > CMakeTmp/etc/FLTK-Targets.cmake
- debian/fix-fltk-targets \
- CMakeTmp/CMakeFiles/Export/share/fltk/FLTK-Targets-none.cmake \
- debian/FLTK-Targets-none-tail.cmake \
+ find CMakeTmp/CMakeFiles/Export -name FLTK-Targets.cmake \
+ -exec debian/fix-fltk-targets debian/FLTK-Targets-head.cmake \
+ {} \; > CMakeTmp/etc/FLTK-Targets.cmake
+ find CMakeTmp/CMakeFiles/Export -name FLTK-Targets-none.cmake \
+ -exec debian/fix-fltk-targets {} \
+ debian/FLTK-Targets-none-tail.cmake \; \
> CMakeTmp/etc/FLTK-Targets-none.cmake
endif
dh_auto_configure -- FTCONFIG="$(PKG_CONFIG) freetype2" \